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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
GETTING STARTED 1

he ASAP Getting Started Guide is intended to help you install ASAP, 
become familiar with its landscape, learn about its features, and do a brief 
exercise.

This chapter describes the contents of your ASAP package: the BRO installation 
media, and, for new users, the hardware key. It also includes information about 
technical support and how to contact BRO.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A S A P  I N S T A L L A T I O N  M E D I A

ASAP installation media provides installers for ASAP and documentation; short 
movies about new features, documentation, and support); and release notes 
(Release_Notes.txt).

Electronic documentat ion
The installation media includes a documentation installer. Running the installer 
will copy all the documentation available at the time of release to your computer in 
C:\Program Files\Breault. Types of documentation are listed below.

1 The ASAP Primer introduces ASAP concepts and use. Each of the more than 20 

chapters are building blocks of knowledge to facilitate new users in 

understanding ASAP.

2 ASAP Reference Guide includes all the ASAP command topics from ASAP 

HTML Help.

3 Over 50 technical publications discuss how to use new and existing features.

You may also download or print ASAP documentation directly from the BRO 
Knowledge Base, which includes the most current versions:

http://www.breault.com/k-base.php

The documents are in Adobe® Acrobat® Reader format (PDF files) so that you can 
read them online, print them, or install them on your computer. The Adobe Reader 
can be downloaded from:

http://www.adobe.com

T
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G E T T I N G  ST A R T E D

BRO Web Site
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . B R O  W E B  S I T E

BRO recommends that you periodically visit its Web site, www.breault.com, to 
find out what is new. Learn about software features and optics training classes, 
view feature or application-specific videos in the Multimedia Gallery, and search 
the Knowledge Base for articles, technical publications, user guides, and white 
papers.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . N E W  A S A P  U S E R S

If you are a new ASAP user, the following items should be in your ASAP package 
or sent to you by email.

Hardware author izat ion key 
The Sentinel® SuperPro™ or SuperProNet™ hardware key is a small device that 
connects to the parallel or USB port of your computer. It contains an identification 
code for using ASAP. See “Installing the hardware key” on page 18.

Software author izat ion keys
Your unique set of alpha-numeric software authorization keys is sent to you via 
email, if you are the end user. You are prompted to enter the keys during the ASAP 
Setup process. The first section of the key is your BRO customer identification 
(ID). After installing ASAP, you can view registration information from the Help 
menu in the ASAP Registration dialog. See “Installing ASAP software” on 
page 18 and “Authorizing use of ASAP” on page 20.
 10 ASAP Getting Started
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. .G E T T I N G  ST A R T E D

Support
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . S U P P O R T

Maintenance Plan
Maintenance Plan members are entitled to major upgrade releases, which occur 
approximately every 12 months, as well as all minor ASAP releases. Major and 
minor releases are available via Web download. Stay current on software, access 
all BRO Light Source Library models, and work with experts in Technical 
Customer Service. 

You will receive e-mail notification of software releases including up-to-date 
ASAP HTML Help, as well as additions to the BRO Knowledge Base and Media 
Gallery at www.breault.com.

Technical  Customer Service
If you are a Maintenance Plan member and you have questions about ASAP that 
are not answered in this manual, in ASAP HTML Help, or the Knowledge Base, 
please contact BRO Technical Customer Service. See “Contacting BRO” on 
page 12. You can expect to receive a response within 24 hours of first contact.

T R O U B L E S H O O T I N G  S T E P S

Please perform the following troubleshooting steps before contacting BRO for 
technical service:

1 Determine which release of ASAP you are running.

2 Note any error messages that occurred while you were working in ASAP, and 

what occurred leading up to the error.

3 Check ASAP HTML Help or the Knowledge Base for information concerning the 

problem or question. The Knowledge Base includes Application Tips for many 

common issues.

Sending your  input  f i les
1 If necessary, send us your ASAP input files (such as *.inr, *.inx, *.enx, *.enz). 

2 To speed up the troubleshooting process, please send a stand-alone file with a 

few lines of sample code to indicate the problem, and explain what you saw and 

what you expected.

3 Include your customer ID and the ASAP version number in your message 

(available on Help> Registration in ASAP).
Getting Started in ASAP  11
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G E T T I N G  ST A R T E D

Engineering Services
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . E N G I N E E R I N G  S E R V I C E S

BRO has over 25 years experience designing, analyzing, and building optical 
products. We analyze and improve the performance of existing designs, or build 
new products to meet customer-defined specifications and requirements.

Our consulting team is staffed by optical, mechanical, and electrical engineers, the 
majority holding advanced degrees.You can use our unique blend of optical 
engineering talent to complement your existing resources, or to serve as your 
primary optical engineering resource.

• Industry expertise: Aerospace/Military, Automotive, Bio-optics, Consumer 
Electronics, Display, Optical Metrology, and Telecommunications.

• Project expertise: Stray Light Analysis, Illumination Systems, 
Coherent/Diffractive Systems, Optical Systems Engineering, and Source 
Modeling.

• Capabilities: Systems Analysis/Design, Feasibility Studies, Prototyping, 
Testing, Custom Software, and Evaluation Services.

For more information, visit www.breault.com, or contact BRO to discuss your 
engineering challenges. BRO is ISO 9001:2000 certified.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . C O N T A C T I N G  B R O

BRO offers several approaches, outlined below, for contacting us about product 
information, technical support, or optical engineering services. We welcome your 
feedback! 

Websi te ,  Phone,  Fax,  E-Mai l
The BRO Web site offers an extensive knowledge base, as well as new information 
on our software products and engineering services, training classes, show 
schedules, newsletters, and press releases. Please bookmark this site and visit it 
periodically to find out what is new.
 12 ASAP Getting Started
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. .G E T T I N G  ST A R T E D

Contacting BRO
Write to us at Breault Research Organization, Inc., 6400 E. Grant Road, Suite 350, 
Tucson, AZ (Arizona) 85715 USA, or phone, fax, or e-mail us: 

Home Page • www.breault.com

Knowledge Base • http://www.breault.com/k-base.php

Software • http://www.breault.com/software/software-overview.php

Engineering 
Services

• http://www.breault.com/consulting/engineering-
overview.php

US/Canada • 1-800-882-5085

Outside US/Canada • +1-520-721-0500

Fax • +1-520-721-9630

E-mail • info@breault.com (product and consulting information)

• support@breault.com (technical questions and feedback)
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ASAP OPTICAL SOFTWARE SOLUTIONS 2

RO offers two editions and several add-ons of ASAP optical software 
solutions to match your optical design requirements. For more 
information, please visit our Web site, www.breault.com.

ASAP Edi t ions and Opt ional  Add-Ons

Edition Solution

ASAP Includes everything necessary to design and analyze your 
imaging and illumination system with the fusion of mechanical 
and optical engineering in mind. Includes REMOTE for 
distributed processing in ASAP.

ASAP PRO Enhanced ASAP edition for complex analyses where coherent 
light propagation and polarization come into play.

ASAP Optional Add-Ons 

(http://www.breault.com/software/asap-optional-addons.php)

BIO Toolkit (for 
ASAP)

Enhanced version of ASAP includes proprietary BRO plug-ins 
for modeling light propagation in biological tissue.

CATIA Module (for 
ASAP)

This module allows ASAP users to open native CATIA V5 files 
from within ASAP. BRO is an adopter of the CAA V5 
architecture, which means CATIA users can count on accurate, 
seamless geometry transitions into ASAP.

ELTM Module (for 
ASAP)

The Exterior Lighting Test Module (ELTM) automates the task 
of SAE, FMVSS, and ECE test compliance for automotive 
industry. The ELTM Module also supports and stores user-
defined tests, walks users through the setup process and 
presents a pass/fail indicator for each test point.

B
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INSTALLING ASAP 3

his section describes how to install, start, and uninstall ASAP, and 
provides computer recommendations.

BRO’s computer recommendations for running ASAP are listed in the 
table below. When determining your computer requirements, BRO encourages you 
to select a system that supports optimum performance for ASAP, and uses 
processor resources intensively for its computation, analysis, and graphical output.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .N E W  A S A P  I N S T A L L A T I O N

A typical new ASAP installation scenario involves the following sequential steps:

1 Installing the ASAP program on your hard drive from the installation media

2 Installing the SafeNet Sentinel™ SuperPro™ or SuperProNet™ hardware key 

on your computer

3 Starting ASAP

During installation, ASAP installs a driver so that the program can communicate 
with the hardware key. The ID of your hardware key is automatically entered in the 
Registration dialog, which is on the Help menu in ASAP.

NOTE Prior to installing ASAP, verify that your hardware key is NOT 
attached to your computer.

See “Installing ASAP software” on page 18 and “Installing the hardware key” on 
page 18 for complete instructions.

ASAP Computer Recommendations

Hardware

Computer Processor For the latest information, please contact BRO 
Customer Service.

Operating System ASAP supports the following systems:
Windows® XP
Windows 2000

Parallel or USB Port Required for hardware key

T
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I N S T A L L I N G  A S A P

New ASAP Installation
Insta l l ing ASAP sof tware
NOTE To install ASAP, you must first log in as Administrator or log 
into an account with equivalent privileges.

1 If the hardware key is attached to the computer, remove it before installing 

ASAP.

2 Insert the installation media into the DVD drive. The autoplay window should 

automatically open.

3 If the autoplay feature is disabled, run d:\setup, where d is the drive designation 

for installation from a DVD.

4 To read the Release Notes, select Release Notes.txt under Install on the autoplay.

5 To install ASAP, click Install ASAP.

6 When prompted, enter your software key, and browse to the folder where you 

want to install ASAP. By default, ASAP is installed in the folder, C:\Program 

Files\ASAPyyyyVvRr, where yyyy is the major year version of ASAP, and VvRr is 

the current version and revision level. Previous ASAP versions are not 

overwritten.

7 Restart the computer after completing the installation.

8 Before you launch the installed ASAP, attach the hardware key (see “Installing 

the hardware key”). If you do not install the key, ASAP opens in Demo mode.

Insta l l ing the hardware key
If you are a new user, BRO includes a SafeNet Sentinel™ SuperPro™ or 
SuperProNet™ hardware key in your ASAP shipment to provide a unique 
identification number for authorizing software use. 
 18 ASAP Getting Started
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. .I N S T A L L I N G  A S A P

New ASAP Installation
The key is a rectangular connector for the parallel port key, or a long, narrow key 
device for the USB port.

Sentinel® SuperPro™ hardware keys (from SafeNet): 797 network parallel port key (top left), single-user key (top 
right), and USB port key (bottom)

NOTE Install ASAP before you attach the hardware key to the 
computer. Attach the hardware key before you launch the installed 
ASAP (see “Installing ASAP software” on page 18).

1 Confirm that your computer system date is set correctly. If it is not, the keys 

could fail.

2 Power OFF the computer.

3 Plug in the hardware key. The arrows on the bottom of the key indicate which 

end to plug into the port.

4 If you are using the parallel port and have other devices you want to attach to it, 

such as printer cable, plug the devices into the other end of the key. The key 

does not interfere with normal use of other devices that you connect to the port.

NOTE You may install ASAP on multiple machines. For ASAP to 
launch successfully on any machine on which it is installed, you 
must either 1) attach your hardware key and register your 
software keys, or 2) be able to access your network key that is 
attached to your ASAP network key server, and register your 
software keys on the local client machine.
Getting Started in ASAP  19



I N S T A L L I N G  A S A P

Starting ASAP
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .S T A R T I N G  A S A P

NOTE Attach the hardware key before you launch the installed 
ASAP.

You can start ASAP from your desktop by clicking , or from the Start menu 
under Programs in a folder you specified during installation.

Author iz ing use of  ASAP
1 The first time you start ASAP after installation, you may need to enter your 

unique BRO software license keys in the Registration dialog, which is on the 

Help menu. If you installed the hardware key, the Key ID number appears in the 

dialog.

NOTE If you do not have BRO software license keys, you can click 
the Demo Mode button on the Registration dialog to preview new 
features or try sample projects.

2 If the license keys are not displayed in the License Key area, enter the key 

numbers from the “BRO Software Authorization Keys” document provided with 

your ASAP shipment.

TIP You can copy the keys from an application like Notepad or your 
e-mail, and then paste them into the Registration dialog via the 
Clipboard. Use the Import From Clipboard button in the Registration 
dialog. Select Help for instructions.

3 Select Update to verify the numbers and store them in ASAP. If the numbers are 

incorrect, a message asks you to re-enter them and select Update again. The 

first set of software key numbers (from the left) is your BRO Customer ID.

4 If you have an ASAP network license, you or your Administrator can locate the 

IP address from the Registration dialog, under Network License Servers.

5 Select Close when you are ready to start ASAP.

NOTE If you have problems during the installation procedure, 
please contact Technical Customer Service.
 20 ASAP Getting Started
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Uninstalling ASAP
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .U N I N S T A L L I N G  A S A P

In accordance with Microsoft guidelines for Windows program installations, BRO 
provides a simple uninstall capability for removing an existing version of ASAP 
from your computer. The uninstaller removes executable, Help, and related 
program files.

CAUTION To preserve the uninstall capability, do NOT alter, rename, 
or delete the uninstall executable and uninstall log files. These 
files reside in the folder in which ASAP was installed. Typical 
names for these files are unins000.exe and unins000.dat, 
respectively.

Uninstal l ing ASAP in  Windows
1 Log in to the Administrator account, or an account with equivalent privileges.

2 From the Start> Settings menu in Windows, select Control Panel and click the 

Add/Remove Programs icon. ASAP is listed along with other installed programs.

3 Highlight the version of ASAP that you want to remove. Select the Add/Remove 

button to uninstall ASAP.

NOTE The ASAP Uninstaller does not remove files that were added 
after the initial ASAP installation. The Uninstaller might not delete 
the folder in which ASAP was installed.
Getting Started in ASAP  21
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
THE ASAP USER LANDSCAPE 4

his chapter introduces you to the layout of the ASAP user landscape—
commonly called the user interface (UI). It is the visible part of the 
program that communicates with the hidden ASAP kernel, taking your 

input from the various windows and dialogs to create and analyze your optical 
systems. When you use the UI, ASAP reformats your input into ASAP command 
syntax. Whether or not you know the exact syntax of commands, you are free to 
focus on the optical engineering task at hand.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .A S A P  P R I M E R  B O O K

BRO highly recommends that you read the ASAP Primer, which introduces ASAP 
in a series of clearly written and illustrated chapters. Based on the ASAP 
Introductory Tutorial course, the Primer includes exercises to help you learn about 
the UI and the ASAP scripting language. A Primer PDF file is on the installation 
media, or find it in our Web Knowledge Base at 
http://www.breault.com/software/k-base.php.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .B U I L D E R ,  S C R I P T I N G ,  O R  B O T H ?

When you are a new user, you might start working primarily with the ASAP 
Builder, in combination with menus and dialogs, to build your optical systems. 
You can also work with the ASAP scripting language. As you personalize the UI to 
suit your needs, you will find ASAP offers a smooth, nearly seamless cross-over 
from the UI to command scripting.

Once you are familiar with the way ASAP works with both the ASAP Builder and 
the ASAP scripting language, you will know which interface is more compatible 
with your preferences.

ASAP will soon become—if it hasn’t already—an indispensable tool for 
designing, analyzing, and prototyping your optical systems.

TIP When you open ASAP for the first time, the main ASAP window 
looks like the illustration in “ASAP window (default mode)”.

T
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T H E  A S A P  U S E R  L A N D S C A P E

Builder, scripting, or both?
TIP BRO recommends that you set your display monitor at 1024 x 
768, with 16 million colors for ASAP. However, 800 x 600 resolution 
with 64K colors is acceptable.

ASAP window (default mode)

See “ASAP Interface” on the Contents tab of ASAP HTML Help. This book, or 
section, includes topics about windows, menus, and toolbars to familiarize with 
ASAP.
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. .T H E  A S A P  U S E R  L A N D S C A P E

Navigating in Help
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .N A V I G A T I N G  I N  H E L P

ASAP HTML Help offers you information on using ASAP. You can access ASAP 
HTML Help in several ways: from the Help menu, by selecting  on the menu 
bar, by selecting the Help button within a dialog, or from the Editor window by 
highlighting a command and pressing F1. 

The ASAP HTML Help window offers you three ways to find information about 
ASAP: Contents tab, Index tab, and Search tab. BRO recommends that you take a 
few minutes to become familiar with Help by browsing the Contents tab (left 
pane). From here, you can see the scope of the entire Help system. 

While the Contents tab gives you a high-level view of all the topics, you can also 
search Help from the Index or Search tabs. The Index narrows your search. It is a 
detailed topic analysis of the contents by topic titles and keywords, which are 
words or phrases contained in or synonymous with a topic. A full-text search 
broadens your search. When you enter a word or phrase in the Search tab, Help 
performs a full-text search and lists all topics in which the actual word or phrase 
appears.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .I N  A N D  O U T  O F  T H E  W I N D O W S

While working in ASAP, several document windows are available for user tasks. 
You can easily move in and out of a window. ASAP Workspace reflects whichever 
window you have in focus:

• ASAP Workspace for viewing lists of open document windows, files, and 
objects.

• Command Input for entering scripting language and viewing the active local (or 
remote) machine, and Command Output for displaying the results.

• Builder and Editor windows for creating and refining your script files, using 
embedded assistants, for digitizing images, optimizing files, or performing 
tolerance analysis.

• Plot Viewer, Chart Viewer, 3D Viewer, and Display Viewer for displaying your 
work in progress, including CIE color analysis, Conformal Radiometry, and 
Polarization (Poincare Sphere).

• Quick Start toolbar for easily accessing sources, glasses, scatter and random 
models, example scripts, interactive scripts, and lenses.
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• BSDF Fit Utility for fitting Harvey and polynomial models.

• Screen Editor window for designing custom dialogs.

NOTE Each of the task windows listed above is described briefly in 
this chapter. Detailed information is available in ASAP HTML Help, 
either in the ASAP Interface book or the Features book.

User  preferences
You can set preferences in ASAP from the File menu by selecting Preferences. In 
addition to general settings, the User Interface Preferences dialog includes settings 
for the Builder, Input/Output, Custom Toolbar Editor, Quick Start toolbar, CAD 
Import, Plot Viewer, REMOTE, and the 3D Viewer. See “User Interface 
Preferences” in ASAP HTML Help.

ASAP Workspace
The ASAP Workspace window initially displays status lists on two tabs, Views 
and Objects. 

ASAP Workspace window with active Views tab
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V I E W I N G  A S A P  W I N D O W S

The Views tab lists all the available ASAP windows. As you open files associated 
with any of these windows, ASAP Workspace lists the open file(s) below the 
window name with which the file type is associated. You can see which files are 
open, and bring a hidden window into focus by selecting the file name on the 
Views tab.
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T R A C K I N G  O B J E C T S

The Objects tab lists all objects associated with an open file. The check box next to 
each object is for designating which objects to include n an operation. See “ASAP 
Workspace” in ASAP HTML Help.

Working wi th  projects
ASAP uses a file management concept called projects. For easy viewing and quick 
access, you can organize each project by linking all the files associated with it. An 
ASAP project file (*.apf) tracks which files are associated with a project, and the 
folder in which each file is stored.
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C R E A T I N G  A  P R O J E C T

1 From the ASAP toolbar, select the triangular arrow next to the New button. From 

the drop-down list, select Project.

2 In the New Project dialog, assign a project name and specify the folder in which 

you want to store the ASAP project file (*.apf). 

TIP Although it is not required, BRO recommends that you store 
your ASAP project file in the same folder as its associated files, if 
possible.

3 From the File menu, select Preferences> General tab, and select your 

preferences for the project.

NOTE The Files tab on ASAP Workspace becomes visible only after 
a project is created or loaded.
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L O A D I N G  A  P R O J E C T

1 From the File menu, select Project> Load. From the Open Project dialog, select 

Files of type: ASAP Project (*.apf), and browse to the folder that includes the 

project file you want. Click Open.

2 After the project files open in the ASAP Workspace window, select a file name 

on the Files tab to open it in its associated window (for example, Builder, Editor, 

or Plot).

O P E N I N G  A  S A M P L E  P R O J E C T

Sample projects are complete working examples of optical systems built in ASAP, 
along with brief documentation in the form of text files.

1 From the File menu, select Project> Load. 

2 Browse asapyyyyvxrx\Project\Samples in your Program Files folder.

3 Double-click a project folder of your choice. 

4 Double-click the project (*.apf) file you want to open. 

Quick Star t  toolbar
The ASAP window includes the Quick Start toolbar on the right, as shown in 
“ASAP window (default mode)” on page 24. The toolbar gives you quick access to

• Light sources,

• Glass media, scatter models and roughness models,

• Example scripts,

• Interactive and user-defined scripts, and

• Lenses.
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Quick Start Toolbar 

See “Quick Start Toolbar” in ASAP HTML Help.

Bui lder
The Builder offers a simple approach to building your system. Designed for both 
new and experienced ASAP users, the Builder introduces you to the concepts of 
using ASAP. You can create the entire system in one window, using most standard 
spreadsheet navigation features, and save it with the file extension, *.enx (XML 
file), or *.enz (compressed XML file). All ASAP commands are available by 
double-clicking an empty cell in the Type column (see figure below).
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Creating a system in the Builder window

The following sampling of features gives you an idea of what you can do in the 
Builder:

• Built-in ASAP command structure

Since you enter Builder input in a sequence that mimics the ASAP command 
structure, you are actually learning about this command structure in a more user-
supportive environment. ASAP automatically translates your input into correct 
syntax, so that entry errors are far less common and easier to identify.

• Preview

Use this feature before entering any Trace or Analysis commands in the Builder. 
Test your geometry (single or multiple items) via the preview capability in the 
Builder. Your geometry is displayed in the 3D Viewer.

• Exploded lenses

View all the component surfaces of a lens in the Builder. These surfaces are 
normally hidden until exploded.

• Tolerancing Analysis
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This feature simplifies the tolerance analysis capabilities of ASAP by making it 
available in the Builder. An automatic Monte Carlo analysis generates random 
perturbations (uniform or normal distribution) to an existing geometry from the 
tolerance table. (Tolerancing is also available in the ASAP Editor.)

• Digitizing

The Digitizer feature is a visual tool for acquiring digitized data from an existing 
Builder file (as well as an INR file) suitable for digitizing for simulation purposes. 
See “Digitizer in ASAP” in ASAP HTML Help.

• View pictures of the geometry

Before selecting geometry from the Builder context menu, you can preview a 
thumb-nail picture of each edge, lens, surface, emitter, and grid command.

• Tear-off command menus

For ease of use, you can detach (or "tear off") a submenu and either dock it to an 
edge of the Builder window, or float it anywhere on the window. Right-click a 
submenu title, such as System and select Dock or Floating.

• Copy and paste

If you need to duplicate information either within the same Builder *.enx file or 
another Builder file, use Copy and Paste to save time and reduce errors.

• Line status

Designate specific rows to include or exclude in your run to experiment with 
results.

For more information on the Builder, see “Defining the System in the Builder” on 
page 53 of the Quick Tour. See “Builder Window Overview” in ASAP HTML 
Help.

Command Input
The dockable and expandable Command Input window is where you enter ASAP 
commands. You can easily work in the Command Input window, and move among 
a variety of other windows, such as the Builder or Editor. 

Command Input window (with entered command)

You can enter commands either by typing the command name or selecting a 
previously submitted command (select the down arrow on the right of the box to 
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see the list). The commands you enter in this window are submitted to ASAP when 
you select Run from the File menu, or press Enter.

You can work interactively from the Command Input Window, or in the 
background (at your system prompt) in batch mode. Since the output files are fully 
compatible with the graphic capabilities in ASAP, you can easily view or 
manipulate graphics.

Command Output
On the left side of the Command Output window, the Explorer view provides a list 
of the files in the current working folder. Local refers to the client computer. If one 
or more servers are also open via REMOTE, a name of each computer is 
displayed. See “ASAP REMOTE” in ASAP HTML Help.

The dockable and expandable Command Output window, on the right, displays 
activity while ASAP runs the commands. Scroll this window to review previous 
output. By default, ASAP saves the last 10000 lines of output for display in the 
scroll window. This number can be adjusted up or down.

TIP Check the activity in the Command Output window during your 
work. It not only echoes the commands you send to the ASAP 
kernel, but also shows warning and error messages to help you 
identify a problem.

Command Output window (right) with the Explorer view (left) and REMOTE toolbar 
(above)

See “Command Input Window” and “Command Output Window” in ASAP 
HTML Help.
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ASAP Edi tor
The Editor window supports basic text input operations, such as editing script 
(*.inr, *.inx, *.txt) files, cutting, and pasting. It can also send the contents of a file 
to the ASAP kernel for processing. A few other examples include embedded 
assistance for writing syntax, color syntax highlighting, keystroke macros, drag 
and drop text, multiple split views, and auto indentation. You can also undock the 
window and resize it, according to your work style. See “Editor Window” in 
ASAP HTML Help.

ASAP Editor window with INR script

The Editor supports a wide range of features, including tolerancing analysis (see 
“Tolerancing analysis in the Editor” on page 40), optimization, and digitization. 
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O P E N I N G  A N  E D I T O R  W I N D O W

You can open an Editor window in one of three ways:

1 From the File menu, select New. 

2 On the main toolbar, select the New button.

3 Press CTRL+N.

G E T T I N G  A S S I S T A N C E

The Editor has more than one method for accessing ASAP HTML Help:

4 From the main ASAP menu, select Help, and then select Editor Help.

5 In the Editor window, highlight a command and select F1 to open the associated 

Help topic or a list of Help topics.

The Editor includes embedded assistants via its smartEditor™ to help you create 
your scripts:

• List of ASAP commands: To find the correct name or spelling of an ASAP 
command, type Ctrl+space to open a scrollable list of alphabetized commands. 
The first name closest to the one you typed in the Editor is highlighted in the 
list. To add the highlighted command in the Editor, double-click its name. Press 
Esc to close the context window.

Embedded assistant: list of commands

• Tips for command syntax: Type a command and press the space bar to open 
the associated command tip. If there is more than one syntax, use the forward 
and back arrows to view them. Click Command Reference at the bottom of the 
tip window to view the Help topic for that command. Note: to activate this 
feature, select Command Tips from the View menu.
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Embedded assistant: command tip

TIP Create or eliminate Editor windows as needed. For example, 
open one Editor for the system geometry, a second window for ray 
initialization and trace commands, and a third for analysis of the 
ray data. Switch from window to window, make the appropriate 
changes, and re-run the input until the analysis is done.
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S E T T I N G  U P  E D I T O R  W I N D O W  F E A T U R E S

The context menu in the Editor window includes a command for opening the 
Window Properties dialog, where you can select colors for various types of syntax, 
add or remove side bars, and change other properties.

ASAP Editor with color-coded script and context menu
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The Window Properties dialog in the Editor includes tabs for: Color/Font, Languages/Tabs, 
Keyboard, and Miscellaneous.

S E L E C T I N G  A  S C R I P T I N G  L A N G U A G E

If you are used to working in a specific scripting language, the Editor supports 
several languages, which you can select from the Editor toolbar: ASAPScript, 
VBScript, JScript, and PerlScript. Select  to view the list.

Q U I C K  S C R I P T I N G  W I T H  T H E  M I N I  B U I L D E R

You can take advantage of the quick scripting of the ASAP Builder while working 
in the Editor by activating the Mini Builder. From an active Editor window, select 
View> Mini Builder, or select . A blank, one-line Builder opens at the bottom of 
the Editor window. Double-click the cell in the Type column and select the ASAP 
commands you want from the drop-down menu. You can move the Mini Builder 
line to the Editor by copying and pasting it or dragging and dropping it. The 
Digitizer feature can be used in the Mini Builder.

Adding a line of script in the Editor with the Mini Builder
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U S I N G  S C R I P T  T E M P L A T E S

Script templates assist in the definition and description of user-specified optical 
systems in ASAP. ASAP provides a collection of pre-defined script templates, or 
you may create your own custom script templates.

The pre-defined scripting templates contain high-level examples of ASAP 
commands used for creating scripts (*.inr files). These examples include system 
definitions, material property definitions, geometry definitions, source definitions, 
trace ray operations, and analysis results.

You can choose a pre-defined script template to import in your Editor file (*.inr). 
Import a template from File> Template by selecting a template listed on the Import 
Template dialog. You must have an Editor window open to access this command.

You can also create your own template to add to the pre-defined script templates 
and export (add) it to the list of templates. From an Editor window, enter the 
command script. Select the script and, from the File menu select Export Template.

P R O G R A M M I N G  C O M M A N D  S T R I N G S  W I T H  T H E  C U S T O M  T O O L B A R

An easy way to program command strings for your frequently used commands in 
the Editor is via the Custom Toolbar. Up to 20 custom command tool buttons are 
available on the ASAP window for programming. See “User Interface 
Preferences/Custom Toolbar Editor Tab” in ASAP HTML Help.

T O L E R A N C I N G  A N A L Y S I S  I N  T H E  E D I T O R

This feature simplifies the tolerance analysis capabilities of ASAP by making it 
available in the Editor when an INX file is open. Analysis options include 
nominal, Monte Carlo, or sensitivity. See “Tolerancing in the Editor” in ASAP 
HTML Help. (Tolerancing is also available in the Builder.

D I G I T I Z I N G

The BRO Digitizer feature is a visual tool for acquiring digitized data from an 
existing INR file (as well as a Builder file) suitable for digitizing for simulation 
purposes. See “BRO Digitizer in ASAP” in ASAP HTML Help.

O P T I M I Z A T I O N  I N  T H E  E D I T O R

The optimization feature in ASAP uses an INR file that is open in the ASAP Editor 
and contains optimization elements, and the Optimization Setup Summary 
window, where your design variables, design objectives, objective constraints, exit 
criteria, and optimization method are specified. See “Optimization - Overview” in 
ASAP HTML Help.
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Screen Edi tor
The Screen (SCR) Editor defines a programmable screen template—a user 
interface—for editing input/output (I/O) dialogs. SCR dialogs can be used to 
create and assign values to ASAP variables. For example, use an SCR-created 
dialog to test a scenario of the same script multiple times with different values.

The SCR Dialog Editor supports the input/output of any ASAP macro. On the 
menu bar, select View> SCR Editor to open the SCR Editor document window. As 
you create the dialog layout in the left pane, the corresponding ASAP script is 
automatically created in the right pane. See “SCR (Screen) Input Editor” in ASAP 
HTML Help.

Screen Editor document window (right) and ASAP Workspace (left)

Path Explorer
The Path Explorer supports the exploration of ray history files via queries that you 
create. Within the user interface or from the Command Output window, you can 
create queries and view results in the BRO 3D Viewer. For more information, see 
“Path Explorer Overview” in ASAP HTML Help.

Plot  Viewer
You can verify that your optical system models are correct before proceeding with 
analysis by viewing them in a ASAP Plot Viewer. From the Project Workspace 
dialog, run the Builder (*.enx, *.enz) or script files you created for your system. 
Create a plot by choosing the appropriate commands from the Display and 
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Analysis menus on the main menu bar, or from the Builder. Use the annotation 
toolbar (shown on the left below) to add text boxes, shapes, lines, and color.

ASAP Plot Viewer window (displaying mesh plot, right-click menu, and annotation toolbar)

See “Plot Viewer Window” in ASAP HTML Help.

Chart  Viewer
The ASAP Chart Viewer window automatically opens in ASAP when data can be 
presented in chart form. You can save chart files in XML file format, and export 
them to another application for presentation purposes. Use the annotation toolbar 
(shown on the left below) to add text boxes, shapes, lines, and color.
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Chart window (displaying a SPOTS POS distribution)

From the File menu, select Save As. In the Save As dialog, select Chart Files 
(*.plx) under Files of Type. See “Chart Viewer Editor” on page 44 to learn about 
changing display features. See “Chart Viewer Window” in ASAP HTML Help.
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C H A R T  V I E W E R  E D I T O R

Chart display features affect the overall appearance of charts generated in ASAP. 
They include those properties and methods that define the color of the chart 
background, titles and their position, margins, borders, background images, frame 
and axis, pen colors and widths, 3D, and walls. Nearly all chart properties are 
available for editing in the Chart Editor. To open the Chart Editor, select  (Edit 
Chart Properties) on the Chart Viewer toolbar.

Chart Editor dialog for applying chart properties

3D Viewer
While ASAP generates 2D plots in the various plot windows, it also stores full 3D 
plot data in a vector (*.vcr) file. To view the contents of the current vector file, 
select 3D View from the System menu or ASAP Workspace. This launches the 3D 
Viewer window, and opens the current vector file in the 3D Viewer.
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Viewing plot data in the 3D Viewer window

For more information, see “3D Viewer Window Overview” on the Contents tab in 
ASAP HTML Help.
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P O I N C A R E  S P H E R E  V I S U A L I Z A T I O N

The Poincare Sphere Visualization Tool (PSVT) displays the polarization state of 
rays in the 3D Viewer. A suitable ASAP display (DIS) file that contains 
polarization data must be available to view the sphere. When you open a DIS file 
with polarization data, the 3D Viewer window changes. A Poincare sphere is 
displayed in the graphics window. See “Polarization - Poincare Sphere 
Visualization Tool in 3D Viewer” in ASAP HTML Help.

C O N F O R M A L  R A D I O M E T R Y

Conformal Radiometry provides a framework for collecting, tabulating, and 
visualizing optical ray data that are spatially localized by their intersections with 
identified surfaces. The feature, which uses the 3D Viewer, can be used to 
determine the distribution of light over a faceted surface. See “Conformal 
Radiometry” in ASAP HTML Help.

Display Viewer
The Display Viewer graphics window displays your distribution data files. You can 
create a picture of the distribution and control contours, palettes, cursors, and 
labeling for better viewing and more exact analysis of your data. See “Display 
Viewer Window Overview” in ASAP HTML Help.
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ASAP Display Viewer window

Right-click context menus are available in the Display Viewer for changing 
display settings. If you change the default settings and want to save the settings for 
future use, select Configuration from the Display Viewer menu, and select Save. 
From the Save Configuration As dialog, open the drop-down box and select one of 
the user-defined views to overwrite.

Save Configuration dialog in Display Viewer
Getting Started in ASAP  47



T I L E  V I E W

To tile multiple Display Viewer windows, right-click Display Viewer in ASAP 
Workspace, and select Tile from the context menu.

3 D  V I E W  O F  D A T A

The 3D feature in the Display Viewer offers a way to visualize portions (or slices) 
of data. The 3D view gives visual height information of pixels, rather than only the 
2D, flat view.

3D view of data in the Display Viewer
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CIE analysis
CIE (International Commission on Illumination) analysis tests for uniformity of 
projected light on a surface. The output is displayed in the CIE window and 
includes chromaticity plots. You can analyze CIE color output, customize data 
display, render color intensity, and view output from CIE color analysis tests.

CIE analysis in ASAP

See “CIE Color Analysis Overview” in ASAP HTML Help. You must have a 
substantial number of rays to see the results.

Optimizat ion
ASAP provides the structure for enhanced optimization capabilities. Included in 
ASAP are three general-purpose optimization methods: Brent’s Method, Downhill 
Simplex, and Simulated Annealing. The Optimization feature in ASAP includes a 
provision for saving the current state of the optimization in a text file.

BRO Digi t izer
The BRO Digitizer allows you to transfer graphical input from an electronic picture 
into numerical data for use with a variety of ASAP commands via a guided user 
interface. You can use the BRO Digitizer to digitize data for context-sensitive 
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commands in the ASAP scripting language (INR files), or in its spreadsheet-style 
Builder or MiniBuilder cells. See ASAP HTML Help for topics on this tool.

REMOTE distr ibuted processing
With REMOTE in ASAP, you can initialize and perform distributed processing 
tasks on dozens, or possibly hundreds, of networked computers by licensing 
REMOTE sessions in bundles ranging from 1 to 100 sessions. The user interface 
gives you control of tasking available computers, processors, and cores, and 
retrieving data from REMOTE sessions

BSDF Fi t  ut i l i ty
In most instances where it is appropriate to apply the Harvey model or the 
Polynomial model, you can use the BSDF Fit utility, which is integrated with 
ASAP.

BSDF Fit utility window 

See “BSDF Fit Utility Overview” in ASAP HTML Help.

.
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A QUICK TOUR OF ASAP 5

erhaps the best way to get an overview of ASAP is from a simple example. 
In this chapter you will create a small concave mirror with a spherical 
surface, and trace rays to see the type of image it produces. The geometry 

consists only of the mirror, and a detector to collect the rays.

Ray trace of concave mirror

Although the problem is simple, we will use the same four steps that are 
fundamental to all ASAP simulations:

1 Building the system

2 Creating the source

3 Tracing the rays

4 Performing the analysis

We will step through this procedure to give you a feel for the process, and then 
look at each of the steps in detail in the next few sections.

Before beginning the work of building a system, there are a few tasks to take care 
of.

P

5 units 1 unit

Mirror diameter = 5 units
Mirror radius of curvature = 20 units
Detector diameter = 1 unit
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Prel iminary tasks
1 Use the Windows Explorer or My Computer to create a new folder for this 

project.

For example, use a folder at the location, c:\ASAP Work and name it Spherical 

Mirror Project. You may select any path that is convenient for you. This is where 
ASAP will store all the working files associated with this project.

2 Start ASAP by double-clicking the ASAP icon on the desktop.

3 From the File menu (on the main toolbar), select Set Working directory.

Choosing your Working Directory

By double-clicking the top-level icon (c:\ drive, for example), you can expand the 
list to see your entire drive. Select the new folder created in the previous step.

4 From the main toolbar, select the triangular arrow next to  (New). From the 

drop-down list, select Builder.

5 From the File menu, select Save As, and give the file a name (for example, 

Spherical Mirror).
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Now for the preliminary steps in the Builder. You can start by defining the 
properties, which tell ASAP about the transmission and reflection characteristics 
of the various surfaces in your system. See the sidebar below, “Defining the 
System in the Builder”.

ASAP is able to calculate Fresnel coefficients with real or complex indices of 
refraction, multi-layer thin-film coatings, or custom coatings specified by your 
own model. But for this problem, we will define some simple ideal coatings for the 
mirror and detector. This first coating is for the mirror.

D E F I N I N G  T H E  S Y S T E M  I N  T H E  B U I L D E R

The ASAP Builder is a spreadsheet-style window for 
defining geometry, properties, and sources, as well as for 
tracing rays and performing analysis. When the Builder 
window is the main focus, the ASAP toolbar changes to 
include the Edit, Preview, and Builder menus. 

ASAP toolbar when Builder is active

Each row is used to enter a single ASAP command. You 
begin entering a command by double-clicking in the left-
most cell of a new row to open a context menu. The menu 
lists all the available Builder commands. Once you have 
entered a command, ASAP generates context-sensitive 
headings at the top of each column applicable to that row. 
The headings prompt you to enter appropriate command 
parameters for the highlighted cell.

Spreadsheet-style rows and columns

Command parameters
ASAP command

Command class Context-sensitive headings

Command parametersCommand parameters
ASAP command

Command class Context-sensitive headingsContext-sensitive headings
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Making a new entry  in the Bui lder
1 Double-click in the left-most cell under the Type column in the first line of the 

spreadsheet.

A context menu of commands opens.

2 From the context menu, select System> Materials> Coatings.

Column headings describe the various parameters in the cells below. The Type 
column displays Coatings and the Cmd column displays Properties.

3 Double-click the cell in the Name column, and assign a name to the coating.

In our example, we have assigned Reflect. We will refer to this type of coating 
later, using this name.

4 Press the Tab key, or click another cell to complete the entry.

5 In the same way, set Reflect 1 to 1 and Transmit 1 to 0.

The coating lets you define an ideal mirror coating that reflects 100% of the 
incident flux and transmits none.

You have finished the first entry. The remaining columns can remain blank. (They 
could be used to define additional reflection and transmission coefficients when 
more than one wavelength is used.)

TIP New entries can go in the next available blank row of the 
Builder spreadsheet, or you can skip lines for ease of reading. 
ASAP ignores blank rows when it runs a file. To insert a new blank 
line, right-click in the Type column and select Insert.

The only other coating you need is an absorbing coating, for placing on the 
detector to stop the rays.

6 Create the coating as in the previous steps, but this time name it Absorb, and set 

the Reflect 1 and Transmit 1 columns to 0.
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Building the System
I N C L U D I N G  O T H E R  P A R A M E T E R S

In many cases, the preliminary setup of our system will also include other 
parameters, like the definition of a set of system units, one or more wavelengths, 
and perhaps the properties of some refractive media. You can skip those 
parameters in this simple example, since you will not be doing anything for now 
that depends on wavelength or the absolute dimensions of the objects.

D E F I N I N G  T H E  M I R R O R

Once the coatings are defined, you can proceed to build the system geometry. Only 
two geometric elements exist in this model: the spherical mirror and the detector.

NOTE Because ASAP is a non-sequential ray-trace program, the 
geometric elements do not need to be defined in any particular 
order. You may start with the mirror.

1 Double-click the left-most cell of a new row, below the coating properties. This 

time, select System> Geometry> Surfaces> Spherical from the popup menu.

Notice how the column headings have changed to correspond to this new 
command.

2 Name this element Mirror.

3 We want to define a mirror perpendicular to the Z axis, which is the default. 

The Z axis is the traditional optical axis for simple systems.

4 Leave the location of the mirror at the origin (Z=0), which is also the default.

5 Give the mirror a radius of curvature of 20 units.

6 Select Ellipse as the aperture shape.

The Aperture column describes the shape of the mirror. By double-clicking this 
cell, you will see the choices in the drop-down box. You want a circular mirror, so 
select Ellipse on the Aperture option.

7 Set both Semiwidth X and Semiwidth Y to 2.5 units, making a circular mirror with 

a diameter of five units.

The remaining columns could be used to place a hole in the aperture. You could 
use this, for example, if you want to make a Cassegrain telescope system. In this 
example, you can leave those cells blank.
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Def in ing opt ical  propert ies
Next, we need to define some optical properties for this mirror. You can give it the 
characteristics of the coating that you named Reflect earlier.

1 Start a new entry by double-clicking the Type column cell, below the mirror 

definition. Select System> Object Control> Object Modifiers> Interface from the 

context menu. Change the coating from Bare to Reflect. 

This gives the mirror the 100% reflectivity you defined earlier. The media on both 
sides of the mirror surface can remain set to the default value: Air. (You would 
change one or both of these in the case of a refractive interface.) You can preview 
the mirror with the BRO 3D Viewer. For information on the 3D Viewer, please see 
ASAP HTML Help

2 From the toolbar, select Preview> All. 

The All menu command shows you a 3D view of the current system.

NOTE While ASAP is preparing data for the preview, you will see 
activity in the Command Output window. As you will see later, this 
window reveals the communication between the ASAP user 
interface and the kernel. You could have achieved the same result 
by sequentially typing the commands into the Command Input 
window yourself.

3 Try to manipulate the system, using the button toolbar above the 3D Viewer 

window. (Each button reveals a ToolTip as the pointer goes over it. The status 

bar includes a more detailed description.)

Def in ing the detector
The final geometric element in this model is the detector. Start this new entry as 
before by double-clicking the left cell of a new row. As always, you can leave 
blank rows, if you like. Select System> Geometry> Surfaces> Plane. Define the 
detector as follows:

Name • Detector

Axis • Z

Location • 10

Aperture • Ellipse

Semiwidth X • 0.5

Semiwidth Y • 0.5
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Building the System
1 View the results with Preview > All to see both the mirror and the detector. Close 

the 3D Viewer.

2 Add the optical properties as before, from the context menu (System> Object 

Control> Object Modifiers > Interface > Coating). This time, replace Bare with Absorb 

to use the coating we defined that neither reflects nor transmits. When we trace 

rays later, this will cause the rays to stop on this surface.

3 Save your Builder file (File> Save).

NOTE Builder files can be saved in two formats: *.enx, an XML 
format and *.enz, a compressed XML format.

The system is now complete. Your Builder window should appear as shown below.

TIP Remember that when you look at the Builder, the column 
headings correspond only to the row or cell that is currently 
selected. In this example, the Detector row was selected.

Viewing Builder entries, with the Detector row selected
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Creating a Source
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .C R E A T I N G  A  S O U R C E

For this example, you will define a grid of parallel rays. This is a two-step process 
in ASAP.

Def in ing a  gr id  of  paral le l  rays in  ASAP
• Define where the rays start.

• Define the direction at which they point.

1 Double-click the first cell of a new row in the Builder, somewhere below the 

geometry definitions. From the context menus, select Rays> Grids> Grid. Set the 

parameters in each Builder column as follows:

Option • Ellipse

Axis • Z

Position • 9

X Axis Min • -2.5

X Axis Max • 2.5

Y Axis Min • -2.5

Y Axis Max • 2.5

X Axis Rays • 100

Y Axis Rays • 100

Aperture • (leave blank)

Random • (leave blank)
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Creating a Source
Illustrated parameters for Grid Elliptic source

These parameters set the location of the starting point of a grid of rays. They are all 
located on a plane perpendicular to the Z axis, 9 units from the origin (the vertex of 
the mirror). They fill a circle of radius 2.5 units. If the array were rectangular, there 
would be 10,000 rays total (100 on a side). Since you asked for an elliptical 
distribution to match the shape of the mirror, the 100x100 rectangular grid is 
trimmed with an ellipse, and the corners will be missing.

NOTE You have placed the rays between the mirror and the 
detector so that no rays can strike the detector before interacting 
with the mirror. In a more realistic model, the detector could be 
made from two surfaces, a front and a back.

2 Double-click the left cell of the next row and select Rays> Grids> Source.

The DIRECTION command sets the directions of the rays. There are three fields to 
set: Vector A, Vector B, and Vector C. These three values are components of a 
direction vector along the X, Y and Z axes, respectively.

3 Set Vector A and Vector B to zero, and Vector C to -1. 

This directs the rays from their starting points near the detector, along the -Z 
direction toward the mirror. The two source-definition lines in the last completed 
row of the Builder window should look like the following figure when you are 
finished:

Viewing Builder entries for ray direction

This is a good time to save your Builder file again.

Mirror

Z=9

2.5

2.5

Ray Grid

Z
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Creating a Source
4 From the File menu, select Save.

T R A C I N G  T H E  R A Y S

Having defined the system and a ray source, the most difficult tasks are done. The 
job of tracing the rays falls entirely to ASAP. ASAP traces each ray from its initial 
position along its prescribed direction, interacting with any objects it finds in its 
path. ASAP makes no assumptions about the order in which the rays strike the 
geometrical elements. (This is the essence of non-sequential ray tracing.) How the 
rays interact with each object depends on the properties of that object. This process 
continues until all rays can be processed.

If you have entered everything correctly into the Builder window, you can expect 
every ray to intersect with the mirror, reflect, and proceed to the detector. Later, 
you will view a profile of the system, and plot some of the rays as they are traced 
to make sure that everything is going as planned.

R U N N I N G  T H E  B U I L D E R

Although you have previewed your system several times, you have never actually 
instructed ASAP to build the system. This is accomplished by “running” the 
Builder to place both the system definitions and the rays into their respective 
databases in memory.

Running a  Bui lder  f i le
1 Start by clicking  (End) on the ASAP toolbar. This initializes ASAP and 

prevents you from running the same system more than once.

2 From the Builder toolbar, click  (Run).

Watch the ASAP Command Output window while ASAP is running. The 
commands sent to the ASAP kernel are echoed in this window. If any errors occur, 
ASAP reports them here. Scroll up the window to check for errors.

See the sidebar, “Errors Found While Running the Builder” on page 61, which 
illustrates what happens when you omit one of the essential parameters in a 
Builder entry. In this example, the number of rays to place along one of the GRID 
dimensions was omitted.
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Creating a Source
E R R O R S  F O U N D  W H I L E  R U N N I N G  T H E  B U I L D E R

If you make an error in the Builder, such as 
leaving out a critical parameter (see above 
illustration), ASAP writes an error 
message to the Command Output Window 
as soon as you run the Builder (see 
illustration on right).

Some parameters in the Builder are 

optional, and some are not. Generally, 
the Builder offers a default value for the 
parameters that are required. In this 
example, the default value for the number 
of rays in the minor axis direction was 
removed, and replacement value was not 
entered. As a result, ASAP has issued an 
error message.

If you make an error, correct it in the 
Builder, click  to reinitialize ASAP, and 
rerun the Builder.
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Creating a Source
G R A P H I C S  F O R  T H E  R A Y  T R A C E

You do not have to graphically plot the ray paths while they are traced, but it is 
useful for verification purposes to plot the ray paths with the geometry. In ASAP, 
ray tracing is an entirely mathematical process, during which ray intersections and 
new ray trajectories are calculated as the rays interact with the various interfaces. It 
generally takes far longer to draw the ray graphics than it does to do the 
calculations involved in tracing rays.

TIP Display at least a few rays as you trace them to verify that the 
rays were created in the right place, and that you pointed them in 
the correct direction.

1 From the toolbar, select Trace> Trace Rays. The Trace Rays dialog controls the 

parameters and geometry of the ray trace.

Parameters for plot window and ray trace plot

2 From the TRACE area of the dialog, select Plot Rays w/ Geometry.

3 In the Plot Ray Options area, enter Ray Trace in the Title textbox. Specify Every 

100th Ray. 

4 Select Override Color, and choose the color in which you would like the rays to 

appear.

5 In the WINDOW area, make sure that Vertical is set to Y and Horizontal is set to 

Z. Check Auto Scale to ensure that the Min and Max values associated with each 
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Creating a Source
axis are set at 0 (the Min/Max values are grayed out). This instructs ASAP to 

scale the plot automatically.

6 In the Plot Geometry Options area, select Profiles.

7 Check Pixel Resolution of Plot, and enter a resolution value of 101.

The Pixel Resolution setting controls the resolution of the graphic, dividing the 
vertical direction into 101 elements.

8 Click OK.

The Command Output and ASAP Plot windows should appear more or less as 
shown below. Some of the values may differ, depending on the speed of your 
computer. However, the Command Output window must be free of errors and 
warnings, and the rays must converge on the detector as expected.

First ray trace plot
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Information about the plot, displayed in the Command Output window

9 Keep the Plot Viewer open. You may close the Builder window.

Performing t racing and analysis  in the Bui lder
So far, we have used the menu items and dialogs to demonstrate the tracing and 
analysis parts of an ASAP simulation. All these actions can be done with 
commands in the Builder file. First, we set the window with the Window command 
from System> Geometry> Verify Geometry> Graphics> Window, and change the axis to 
Z. Next, we set the Pixels command from System> Geometry> Verify Geometry> 

Graphics> Pixels.

Now, we can choose to look at a faceted plot or a profile of the system geometry, 
or both. If all the plots are to be viewed in the same window, use the Overlay 
option to keep open the plot window for the next plot. In our case, use the Overlay 
option for the Profiles and Plot Facets choices. However, do not use the option on 
the Trace Plot command, since this would leave the plot window open for the 
analysis plots. The ray trace and plot commands are found on Trace> Trace. Select 
the Plot option on the Trace command. The Builder file should now look like the 
following figure.

Trace Plot command added

The same graphics resulting from the dialogs are produced again. Verify the results 
by running the Builder file.
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Performing the Analysis
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .P E R F O R M I N G  T H E  A N A L Y S I S

The last step in the process is analyzing the results. In this case, you will see the 
type of image you have produced on the detector. Begin by making a spots 
diagram that shows where each ray landed.

Making the spots diagram
1 From the Analysis menu, select Calculate Flux Distribution to open the Calculate Flux 

Distribution dialog.

Settings for the spots diagram

2 In the Method section, select Flux/Area (Irradiance using SPOTS POSITION).

3 Select Plot all rays from the Plot section, and enter Spots Diagram in the Title 

textbox.

4 In the WINDOW section, select Y for Vertical and X for Horizontal. Select Auto Scale.

5 In the PIXELS Resolution section, enter 101 in the Vertical Elements in Window 

textbox, and 1.000 in the Aspect Ratio textbox.

6 Click OK to produce the diagram.
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Spots diagram

NOTE The spots diagram shows some plotting artifacts resulting 
from the regular nature of the grid source you used, rather than 
from the optical properties of the objects.
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B E S T  F O C U S

You placed the detector at a position equal to half the radius of curvature of the 
spherical mirror. But is this the best focus? ASAP has, among its many analytical 
tools, a utility that shifts the rays along their trajectories to find the best root mean 
square (RMS) focus.

Determining best  focus
1 From the toolbar, select Analysis> Focus Rays. 

You will see the dialog shown below. 

Move rays to plane of best focus

Ask ASAP to move the rays to the plane of best focus. Click OK.

When you click OK, you will see, by looking in the Command Output window, that 
the best RMS focus is actually at Z=9.947485, rather than 10 units where you 
placed the detector.

Best focus output

2 Next, make another spots diagram to see the effect of the small shift in focus.

This change is quite noticeable, both in the appearance and size of the resulting 
spot. From the scale of the two diagrams, notice that the overall size of the spot 
was reduced by a factor of three, as theory predicts.
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Spots at best RMS focus

The values displayed are the X and Y coordinates of our autoscaled window at the 
Z-position of 9.947.

NOTE Compare the change in scale between the X (vertical) extent 
of this spots diagram with the previous diagram performed, with 
the rays located at half the radius of curvature.

Before proceeding to visual analysis results, we will create the Builder commands 
to produce the same results as shown above for the Spots diagram, before and after 
determining best focus.

The window needs to be reset so that we can view the results perpendicular to the 
propagation axis of the rays; that is, the plot window should be in the X-Y plane. If 
the pixel value needs to be changed for the analysis, this is the time to make the 
change. These commands are found on the Builder menu: System> Geometry> Verify 

Geometry> Graphics> Window, and on System> Geometry> Verify Geometry> Graphics> 

Pixels. Let ASAP autoscale the window size. Select 101 (or some other value) for 
the pixel resolution, as was done above in the dialogs for these two settings.
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Performing the Analysis
Finally, the Spots diagram is on the Builder menu: Analysis> Calculate Flux 

Distribution> Spots. Since the detector is not placed at the best focus position (we do 
not know the best position yet), we need to find the best focus position on Analysis> 

Focus> Spots. Repeat the commands for the plot window and the spots diagram 
after the Focus Move column. The Builder file should now have the following 
appearance for the recently added commands.

Spots position

The graphics results are the same as those produced with the dialogs. Verify these 
results by running the Builder file.
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Once the spot diagram has been made, these results can be further analyzed with a 
variety of analysis and visualization tools on the Display menus. We will highlight 
just a few of them.

NOTE If the ASAP toolbar does not show the Display menu, the 
window that is in focus needs to be changed. Click in the ASAP 
Workspace window to return to the main ASAP toolbar.

Using the v isual izat ion tools
1 From the toolbar, select Display> Graphics> Picture.

You will see the regular patterns again, which result from our use of a rectangular 
grid of rays with fixed spacing.

Spots diagram in Display Viewer window
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2 Next, apply some averaging. From the Display menu select Processing> Average. 

In the Display: AVERAGE dialog, click Average Over 1 Adjacent Pixel. Click OK.

Apply averaging

3 Make another picture with Display> Graphics> Picture to see the effect. 

Effect of averaging over one adjacent pixel
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You can change the display settings by right-clicking in the area of the Display 
Viewer that you want to change. 

4 Next, from the Display menu, select Graphics> Isometric.

Display isometric plot

5 Enter Best Focus Isometric in the Title textbox, and 1 in the Abscissa Magnification 

textbox. Click OK to view the plot in the ASAP Chart window.

Best focus isometric plot
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Visualizing the Results
Finally, do a radial average of the image and plot with a cross-section of the 
averaged image, and the enclosed energy as a function of radius.

6 Select from the Display menu, Graphics> Radial. Use the options shown in the 

Display: RADIAL dialog below to explore where the flux is concentrated at the 

image.

Radial averaging of plot
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Visualizing the Results
Plot of radial average and integral

Performing v isual izat ion in  the Bui lder
Now, Builder commands for the visualization tools will be used. The Display 
command uses a file created with the Spots Distribution command. The Picture 
command is a good way to visualize the flux distribution command. 

1 Display and Picture are found on Analysis> Display> Display and Analysis> Display> 

Graphics> Picture. 

2 Find the picture results with and without averaging. 

3 Perform the Display command again, before averaging the numbers in the 

distribution file.

Finally, we want to look at other views of the distribution file. An isometric view 
and a radially averaged view are both useful for seeing some summary 
characteristics of the distribution. 

4 Find the viewing commands on Analysis> Display> Graphics> Isotropic and on 

Analysis> Display> Graphics> Radial. 
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Summary
The Builder file now ends with the last commands we just used.

Radial command added

The graphic results are, once again, the same as those produced with dialogs. 
Verify this by running the Builder file.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .S U M M A R Y

While completing this quick tour of the basic ASAP analysis process, you worked 
through the four basic steps required for all ASAP work:

• Creating a system, including geometrical entities, and assigning optical 
properties to these entities.

• Creating a source.

In this case the source was a grid of parallel rays. This may represent an extended 
source at infinity or a collimated source.

• Tracing the rays through the system and onto a detector.

• Performing some basic analysis.

You looked at a spots diagram before and after finding the best focus. After 
making a spots diagram, you created a distribution file, sorting the rays according 
to their location on the detector. This tour was a starting point to other forms of 
analysis and visualization, such as averaging.
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Summary
Much more is possible during each of the four stages. ASAP excels at providing 
you with the flexibility to apply a powerful set of tools to a large range of 
problems.
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IMPORTING AND EXPORTING 6

ou can import or export several types of files, either those generated by 
ASAP or those used as inputs to ASAP. These file types are outlined 
below. For more detailed information, see Importing/Exporting in ASAP 

HTML Help. 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .B R O  L I G H T  S O U R C E  L I B R A R Y  A N D  W I Z A R D

The BRO Light Source Library, available to ASAP customers with current 
software maintenance agreements, is a collection of U.S. and European source 
models that can be imported directly into ASAP projects. Current sources include 
filament, light-emitting diode (LED), arc, and cold cathode fluorescent (CCF). The 
Light Source Library reduces planning and prototyping costs by eliminating the 
need to scan, measure, and model industry sources.

To view a catalog of sources, go to the BRO Web page:

www.breault.com/software/asap-lightsourcelib.php.

Once ASAP is installed, you can access the Library either from the Quick Start 

toolbar on the Sources tab, or from the Rays menu in ASAP. A wizard is available in 
ASAP to walk you through the process of using the library. 

Two main steps are required when using the BRO Light Source Library wizard: 
Create and save rayset(s), and Writing ASAP script commands to a template. Each 
of these steps is described in ASAP HTML Help, and in the technical publication, 
ASAP Light Source Library Wizard.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .E X T E R I O R  L I G H T I N G  T E S T  M O D U L E  ( E L T M )

The Exterior Lighting Test Module (ELTM) imports your geometry files to 
determine whether it is in compliance with standard government lighting tests. For 
more information, see “ELTM - Exterior Lighting Test Module Overview” in 
ASAP HTML Help. ELTM is an optional add-on for ASAP.

Y

Getting Started in ASAP  77

http://www.breault.com/software/asap-optional-addons.php


I M P O R T I N G  A N D  E X P O R T I N G

CAD Support
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .C A D  S U P P O R T

IGES f i les
ASAP includes an integrated IGES file translator, smartIGES™. You can translate 
IGES (Initial Graphics Exchange Specification) files to ASAP format for 
performing optical analyses on geometries initially created in a CAD program. 
Using the IGES files translator, you can import your Rhinoceros® (Rhino) models 
as system geometry for optical analysis. 

ASAP also supports exporting CAD files with IGES. See ASAP HTML Help.

Sol idWorks geometry
Use the SolidWorks Parts Only 3D modeling engine with ASAP to assign object 
and layer names. Import SolidWorks® geometry files from SolidWorks, with 
ASAP. These files are saved in the GTX file format via the Save As dialog. 

XML-based CAD f i le  format  for  Rhino
ASAP supports an XML-based CAD file format for Rhino. It contains information 
about the geometry, and the optical properties of each object. Optical information 
stays with the geometry when going between the codes.

CATIA f i les
Users can import CATIA files via the CAA V5 plug-in with the optional add-on 
CATIA Module for ASAP.

C O D E  V ,  O S L O ,  S Y N O P S Y S ,  A N D  Z E M A X  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .F I L E S

ASAP PRO includes the fully integrated capability of importing CODE V®, 
OSLO®, SYNOPSYS™, and ZEMAX® files. You can open these file types (*.seq, 
*.len, or *.zmx) in ASAP from the Open dialog on the File menu.

With the Zemax translator, you can import an existing ZEMAX file into ASAP, 
and set preferences for translating the ZEMAX lens design data, surface type 
options, and output options in ASAP. From the ZEMAX data, ASAP calculates the 
location and orientation of each surface in a single global coordinate system, 
determines the transformation matrix for each surface required to transform the 
surface from its local coordinate system to the global coordinate system, and 
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decomposes the transformation matrix into the angles and positioning variables 
required by ASAP.

The GLA2CAT utility in ASAP converts a ZEMAX.AGF catalog or an 
OSLO.GLC glass catalog to an ASAP.CAT format. For information, see the Help 
topic, “Converting Lens Design Glass Catalogs”.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .D X F  F I L E S

ASAP includes a bidirectional DXF/CAD (digital exchange format/computer-
aided design) conversion. ASAP can convert all AutoCAD® DXF surface 
definitions (and BLOCKS)—up to and including AutoCAD release 12—to ASAP 
EDGE-based objects. For importing, use the file, Dxf2asap.exe in the asap\bin 
folder on your hard drive. For exporting, select Export to CAD on the File menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .R E F L E C T O R C A D  F I L E S

You can use ASAP to check the output of a reflector you created in 
ReflectorCAD™. Follow instructions in ReflectorCAD Help for changing 
appearance-related settings in ReflectorCAD for output appearance and 
contouring. Before exporting the ReflectorCAD file to ASAP, you must convert 
the ReflectorCAD file to an ASAP *.inr input file. Use the Export>To ASAP 
command in ReflectorCAD on the File menu to do this step. (You may also import 
an ASAP source distribution file into ReflectorCAD with the Dis2Sdf.exe utility. 
(See the ReflectorCAD User’s Guide.)

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .A P A R T  F I L E S

If you are an APART™ user, two conversion programs are provided in APART for 
converting system data into ASAP input: AP2RBS and AP2RBE.
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Plot Files
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .P L O T  F I L E S

The utility, HPGLNP.exe reads ASAP plot (*.plr) files and creates Hewlett-
Packard files to export for plotting. The PSCSRIP.exe utility reads ASAP *.plr 
files and creates PostScript files for printing. Both utilities are in the <asap 
install>\bin folder on your hard drive.
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