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Chapter 1

A Quick Tour

This chapter introduces ReflectorCADTM by way of example. It provides step-by-step in-
structions and illustrations for building a simple reflector. By following through this example,
and the chapter that follows, you will be exposed to most of the principles required for using
ReflectorCAD effectively.

1.1 Typical Reflector Design Steps

The typical steps involved in designing a reflector with ReflectorCAD are as follows.

Choose a base surface All segments are initially created on the base surface. Vertex and
segment heights are measured relative to it. Typically, this surface approximates the
desired shape of the finished reflector. Simple built-in base surfaces are provided.
Alternatively, virtually arbitrary surfaces can be imported from an IGES file.

Select a light source One or two light sources (bulbs) can be used. Only one source can
be on at a time. The source is used for calculating the reflector’s approximate output
and aiming segments.

Create and aim segments Segments are created graphically using the mouse. Each seg-
ment is directed to illuminate a specific region by moving and reshaping its aim box in
the Output view. Approximate reflector output (either positional or directional) can
be quickly calculated at any time to aid in making aiming decisions.

Adjust intersegment discontinuities For both performance and manufacturability rea-
sons it is generally best to minimize height discontinuities between segments. Where
such discontinuities are necessary they should normally be hidden from the source (in
otherwords, shadowed) to prevent undesired stray reflections. This can be done by
adjusting segment aims and/or starting point heights. A simple method for checking
edge shadowing is provided in ReflectorCAD.

Export the reflector design Reflector designs can be exported to ASAPTM (via an INR
file) or a CAD package (via an IGES file). Other geometric elements (for example, the
bulb holder or shelves) can then be added. With this additional geometry in place,
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Figure 1.1: The main ReflectorCAD window is shown with key features delineated. In this
case the window is shown with the Reflector view above the Output view in a vertical layout.
This can be changed to a horizontal layout on the View menu.

further analysis should be performed using an optical analysis package, like BRO’s
ASAP.

1.2 Main Window Layout

Figure 1.1 shows features of the main ReflectorCAD window. The reflector faces in the
+Z-direction and is viewed looking in the -Z-direction. In otherwords, if the reflector were
a headlamp we would be viewing it from in front of the car. The output is viewed looking
in the +Z-direction, as if we were in the car looking at the output on a wall in front of the
car. See figure 1.2.

1.3 Design Goal

Our design goal in this quick tour is to create a reflector that produces an output pattern
qualitatively similar to that shown in figure 1.3. We want a square hotspot at 2◦ below the
center and a relatively even spread from −15◦ to 15◦ horizontal and 0◦ to −6◦ vertical.
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Figure 1.2: Viewpoint orientation for the Reflector and Output views.

Figure 1.3: The desired output pattern for the quick tour reflector.
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Figure 1.4: Initial appearance.

Figure 1.5: Setting the system units.

1.4 Preliminary Steps

Start ReflectorCAD, if you have not already done so. The main window opens with an initial
appearance similar to that shown in figure 1.4. Before we can create our first segment, there
are some preliminary steps we must go through. These include setting units, choosing a base
surface, selecting a light source, and specifying the output properties.

1.4.1 Set the System Units

Set the system units by selecting System Units on the Setup menu (for the rest of this
tour a menu operation like this will be denoted as Setup > System Units). Set the units
to ‘millimeters’ as shown in figure 1.5.
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Figure 1.6: Setting the base surface properties.

1.4.2 Choose a Base Surface

The base surface defines the height (Z coordinate) for the starting point of new segments. It
also specifies the reflector’s boundaries (in the X-Y plane). Select Setup > Base Surface
Properties and fill in the dialog as shown in figure 1.6. This will make the base surface a
parabola (because the Conic Constant is -1) with a focal length of 40 mm (because the
Radius of Curvature is 80 mm). By shifting the base surface -40 mm along Z, we place
the focus at the origin. The outer boundary is rectangular with rounded corners (this is
called a Racetrack). The circular inner boundary serves as the bulb hole.

1.4.3 Choose a Light Source

Choose a light source (bulb) by selecting Source > Properties (or by pressing the

button on the toolbar) and filling in the dialog as shown in figure 1.7. Press the button
to select the HB3 bulb from the Head&FogLamps source directory. Once the bulb is
selected, click the View Model button to get details on the source model. Note that the
filament for this source is 31.5 mm above the reference point. We are positioning the reference
point at (0,0,-48), which will place the filament 16.5 mm inside the base surface’s focus at
the origin.

The Effective Filament Position (EFP) is reported in the dialog’s lower right corner
when a valid source has been selected. This is usually the best focus of the rays used to
create the source model. Notice that for this bulb, as would be expected, the EFP is very

5



Figure 1.7: Setting source properties.

close to the bulb’s filament center. If the Relative to effective filament position box
were checked (it shouldn’t be in this example) then the EFP would be used as the bulb’s
reference point for positioning.

Only one source is needed in this example, so only the Source 1 tab should be filled in.

1.4.4 Set Output Properties

Select Output > Properties (or click the toolbar button) and fill in the dialog as shown
in figure 1.8. For this example we want far-field directional output with a vertical range of
−6◦ to 6◦ and a horizontal range of −15◦ to 15◦. The vertical resolution is chosen to provide
3 pixels per degree, while the horizontal resolution provides half degree pixel spacing. The
Reflector reflectance (85%) and Lens transmittance (90%) act as simple scaling factors
on the calculated output.

1.4.5 Grid and Snap Settings

To aid in positioning segment vertices and aim points, ReflectorCAD provides grids that can
be snapped to. In the Reflector view, right click and select Grid/Snap Settings from the
popup menu that appears. Fill in the dialog as shown in figure 1.9 (left image). Following
the same steps in the Output view, fill in the dialog as shown in figure 1.9 (right image).
Finally, make sure the grid and snapping are enabled by checking the Enable Grid and
Snapping item on the popup menu in each view.

6



Figure 1.8: Setting output properties.

Figure 1.9: Reflector view (left) and Output view (right) grid/snap settings.

1.4.6 Set Default Segment Aiming

Set the default aim, which is assigned to new segments upon creation, by selecting Segment
> Default Aiming and filling in the dialog as shown in figure 1.10. This will give new
segments a 10◦ horizontal and 4◦ vertical spread. Checking the Save as defaults for new
reflectors box makes these the defaults each time ReflectorCAD starts up.

1.4.7 Enable Automatic Output Recalculation

Enable automatic output recalculation by making sure the Output > Auto Update menu

item is checked or the toolbar button is pressed down. When this option is enabled
reflector output is calculated automatically whenever a relevant change is made. Because
output calculation can often take several seconds, it is sometimes quicker to work with this
option disabled when making a series of changes. In such a case output can be calculated at

any time by pressing the button.

7



Figure 1.10: Setting defaults segment aiming.

1.5 Create and Aim the First Segment

Now that we’re done with the preliminary steps, it’s time to create the first segment. Begin

by clicking the button on the toolbar. In the Reflector view, place the cursor at (0,0)
and click to define the first corner. Then move the mouse to (50,40) and click to define the
opposite corner. Note that the current mouse coordinates are displayed in the status bar at
the lower right corner.

If you make a mistake while creating the segment, pressing the Esc key will cancel the
creation. Alternatively, after any segment change (including creation of a new segment),
selecting Segment > Undo Last Segment Change or pressing Ctrl-Z will undo the last
change.

At this point, the Reflector view should look similar to figure 1.11. The new segment,
labeled S1, is automatically selected as the current segment following its creation. The
output produced by this segment is shown in the Output view, and should look similar to
figure 1.12.

When a segment is selected its aim box is shown with the output. Unselect the segment
by clicking in the reflector view outside of the segment. Note that the aim box is no longer
drawn in the Output view. When no segment is selected the combined output for all segments
is displayed. Now, select the segment by clicking inside it. Note that the vertex closest to
the cursor is highlighted with a green box when the segment is selected. If you click near
another vertex inside the segment then it will be highlighted, instead. In the Output view,
the corresponding aim point is also highlighted with a green box. This shows where on the
output screen this particular vertex is to direct its light.

1.5.1 Change Segment Properties

With the segment S1 selected, right-click in the reflector view and select Segment Prop-
erties from the popup menu that appears. Fill in the dialog as shown in figure 1.13. The
Save as defaults for new segments box is checked so all other segments we create will

8



Figure 1.11: Reflector view after creation of first segment.

Figure 1.12: Output view after creation of first segment.
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Figure 1.13: Setting segment properties.

have these same properties. Click the Help button for information on what the settings in
this dialog mean.

1.5.2 Segment Contouring

Contours are drawn inside the segment in the Reflector view. They indicate height (along
Z) measured relative to the base surface. Red contours denote a positive distance (e.g.,
the segment is above the base surface) and blue contours denote a negative distance. The
contour colors fade as the height of the segment moves further from that of the base surface.
Set the segment contouring properties by selecting the Segment > Contouring menu item
and filling in the dialog as shown in figure 1.14. This sets the contours to range from -10 to
10 millimeters relative to the base surface with 10 contours on each side of 0. So one contour
will be drawn for every 1 millimeter of deviation from the base surface.

1.5.3 Change the Segment’s Aim

The next step is to change the segment’s aim. To begin, ensure the segment is selected by
clicking inside of it, in the reflector view. Next, in the Output view, right click and select
Move from the popup menu that appears. Then move the aim box to the new location
shown in figure 1.15, and click. Next move the aim box’s top edge to a new location by
dragging the corresponding red square as shown in figure 1.16. Finally, drag the left edge as
shown in figure 1.17.
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Figure 1.14: Setting segment contouring.

Figure 1.15: New location of segment’s aim box after move.

Figure 1.16: Dragging top edge of aim box.
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Figure 1.17: Dragging left edge of aim box.

1.5.4 Redevelop the Segment

Each time a segment’s aim changes, ReflectorCAD automatically reshapes the segment to
achieve the desired aim. This is called developing the segment. The aim is used, along with
the specified source point, to determine the necessary surface normals. These normals are
in turn integrated, starting from the specified vertex (called the starting point), to form
the segment’s new shape. By default, the starting point is the first vertex laid down when a
segment is created. For our segment S1 this is the lower left corner.

During integration, the segment’s prior shape is used as an approximation for its new
shape to help evenly balance flux across the aim region. To the extent that the prior and new
shapes are similar, this approximation is good. If a segment’s shape changes substantially
its performance can often be improved by redeveloping it after the last aim change.

To redevelop segment S1, first ensure it is selected. Then right click in the Reflector
view and select Redevelop from the popup menu. In this case, because the segment aim
changes were small, the segment’s output pattern should change only slightly.

At this point, it’s a good idea to save your work by selecting File > Save or by clicking

the button on the toolbar.

1.5.5 3D Preview

To see what the segment looks like in three dimensions, select View > Generate 3D

View or click on the toolbar button. After a few seconds a separate 3D Viewer window
should appear, similar to that in figure 1.18. The segment and a cylinder representing the
source model are shown in the viewer. The view can be rotated by moving the mouse while
holding down the right mouse button. See the 3D Viewer help for information on the other

manipulations available. When done with the 3D Viewer window, close it by clicking the
button in the upper right corner.
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Figure 1.18: 3D view of reflector with one segment created and aimed.

1.6 Create and Aim More Segments

1.6.1 Segment S2

Create a second rectangular segment, starting at (0,40) with the opposite corner at (50,70).
The Reflector view should now look like figure 1.19. Change the aim of the new segment as
shown in figure 1.20.

1.6.2 Segment S3

Create a third rectangular segment, starting at (50,0) with the opposite corner at (100,70).
The Reflector view should now look like figure 1.21. Move and change the width of the
segment’s aim box to match that shown in figure 1.22.

Try selecting the different segments with the mouse. Notice that only the selected seg-
ment’s output is shown in the Output view. If no segment is selected, the combined output
from all segments is shown.

1.7 Intersegment Discontinuities

1.7.1 Checking Intersegment Discontinuities

Generate a three-dimensional view of the reflector, by clicking the button. Rotate the
view by moving the mouse while holding down the right button and note the discontinuities
between adjacent segments, as shown in figure 1.23. It is generally a good idea to minimize

13



Figure 1.19: Reflector view following creation of second segment.

Figure 1.20: Changing aim of segment S2 .
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Figure 1.21: Reflector view following creation of third segment.

Figure 1.22: Output view showing desired aim for segment S3 .
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Figure 1.23: 3D preview of reflector highlighting intersegment fillers.

Figure 1.24: Checking edge shadowing between segments S1 and S2 .

such discontinuities and ensure they are hidden from the source (shadowed) to avoid stray
reflections. In this case the discontinuity between segments S2 and S3 is exposed to the
source. The other two discontinuities, while shadowed, are large.

ReflectorCAD also provides a more quantitative method for checking edge shadowing.
To check the edge between segments S1 and S2 , first select S1. Then, with the cursor in
S2 , hold down the shift key and left mouse button simultaneously (note this will also work
with S1 and S2 reversed). A titletip similar to that shown in figure 1.24 will appear. It
indicates that S1 shadows the edge of S2 by at least 8.09 mm along their common edge.
Since the edge is shadowed, the message is colored green. If the edge had not been shadowed
it would instead be colored red. The box containing ‘-8.1’ is conveying the same information
as the titletip, and indicates which edge is being checked.
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Figure 1.25: Changing height (Z position) of starting point for S2 (left) and S3 (right).

1.7.2 Reducing Intersegment Discontinuities

The discontinuities can be reduced by adjusting the relative segment heights. First select S2
and its lower left vertex, by clicking inside S2 near this vertex (the lower left vertex is chosen
because it’s the segment’s starting point). Then right click and select Vertex Properties
from the popup menu. Change the Z Position to be 5 mm above the base surface as shown
in figure 1.25 (left side). Note that the discontinuity between S1 and S2 is now greatly
reduced. Further, the discontinuity between S2 and S3 is now shadowed. Proceeding in a
similar fashion, change the lower left vertex (starting point) of S3 to have a Z Position of
2.7 as shown in figure 1.25 (right side)

1.7.3 Redevelop All Segments

Since the segment height changes were fairly large it’s a good idea to redevelop the affected
segments (S2 and S3 ). Since there’s only one unaffected segment it’s easiest to redevelop
them all by selecting Segment > Redevelop All Segments. After developing, save your
work and then generate a three-dimensional preview to check the discontinuities.

1.8 Finishing the Reflector

1.8.1 Mirror Segments

At this point, the total output from the reflector, with only one quadrant complete should
look similar to figure 1.26. This is essentially one half of the pattern we are looking for.
The next step is to mirror the segments about the Y axis to produce the other half. Select
Segment > Mirror Existing Segments and fill in the dialog as shown in figure 1.27 (left
side). This will create 3 additional segments with mirrored vertices and aiming (because the
Mirror aim points box is checked).

With the top half finished, next create the bottom half by mirroring about the X axis.
Because we only want output on the lower half, the Mirror aim points box should not be
checked this time, as shown in figure 1.27 (right side).
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Figure 1.26: Total output from first quadrant

Figure 1.27: Mirroring about the Y axis (left) and then X axis (right).
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Figure 1.28: Adjusting aim of segment S13.

1.8.2 Replace Two Segments

Generate a three-dimensional preview of the reflector. Note that the two segments in the cen-
ter at the bottom (S8 and S11) have large discontinuities with their neighboring segments.
Rather than adjust these segments we’re going to replace them with a single segment. Select
segment S8 and delete it by pressing the Delete key (or selecting Delete Segment from
the popup menu). Do the same for segment S11. Next create a new segment in their place,
starting at (-50,-40) (the upper left corner), with the opposite corner at (50,-70). Adjust the
aim for the new segment as shown in figure 1.28.

Finally, adjust the starting point height of the new segment. Select S13 by clicking inside
it, near the upper left vertex (the segment’s starting point). Adjust its Z Position to 5mm
above the base surface. Because the height change is significant redevelop S13, by selecting
Redevelop from the popup menu.

1.8.3 The Reflector’s Finished

The reflector should now be finished. This is a good time to save your work. The Reflector
view should look similar to figure 1.29. Figure 1.30 shows the total output for the reflector,
which achieves our initial output goal. This completes the basic quick tour of ReflectorCAD.
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Figure 1.29: View of finished reflector.

Figure 1.30: Total output of finished reflector.
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Chapter 2

Further Exploration

This chapter explores some aspects of using ReflectorCAD that weren’t touched on in the
basic quick tour. To follow along, use the reflector created in the quick tour above.

2.1 Setting Output Contour Levels

It is often useful to have output contours drawn for specific levels. Change the contour levels
by selecting Output > Contouring. Delete any existing contour set(s) by selecting them
and clicking the Delete button. Then, by clicking the Add button, add the single value
contours for the levels shown in figure 2.1. Whether contours are displayed is controlled via
the Show setting on the Output Appearance dialog (accessed by selecting Output >
Appearance).

Figure 2.1: Setting fixed contour levels.

21



Figure 2.2: Exporting to ASAP.

2.2 Exporting to ASAP for Further Analysis

It is always important to remember that ReflectorCAD’s output calculations are approx-
imate (see section 3.4.1 (page 36) for more details). A more thorough evaluation of the
reflector should be performed using an optical analysis package, like BRO’s ASAP. Gener-
ally this should be done after completing the design in ReflectorCAD and then, again, after
all remaining geometric elements (e.g., the bulb holder, lens, and shelves) have been added
to the design.

To export the reflector design to an ASAP input file, select File > Export > To
ASAP and fill in the dialog as shown in figure 2.2. Note that a stored rayset for the HB3
bulb, which our reflector design uses, will have to be downloaded (or generated) before the
exported file is run in ASAP. Also, note that the Base path should be the directory where
your ASAP light source files are stored and may differ from that shown in the figure. The
Source file suffix entry shown assumes that the 500,000 ray version of the source is used.
The Base path and Source file suffix, are combined with the source’s name (HB3) to
form the complete source file name used with the EMIT DATA command in the ASAP
input file.

When run in ASAP, the resulting output resembles that shown in figure 2.3. The corre-
sponding output calculated in ReflectorCAD is also shown for comparison.

2.3 Measuring Vertical Gradients

ReflectorCAD provides a convenient method for measuring vertical gradients in the reflector’s
output. In the Output view, right click and select Gradient Query Settings from the
popup menu. Fill in the dialog as shown in figure 2.4.

To measure the vertical gradient at a location in the output, hold down the left mouse
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Figure 2.3: Comparison of output calculated in ReflectorCAD (top) and ASAP (bottom).
The ASAP calculation used 500,000 source rays and yielded a total flux of 957 lumens.
Contours were added manually in ASAP’s display window.

Figure 2.4: Gradient measurement settings.
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Figure 2.5: Measuring vertical gradient for output of segment S3.

Figure 2.6: Adding a source point at the inner filament end.

button while also pressing the control key. A small graph tip, similar to that in figure 2.5,
will popup. As the mouse is moved the graph and values update. The plot shows the vertical
gradient calculated along the I-shaped cursor. The gradient at the cursor location and the
max gradient along the cursor bar are amongst the values displayed. The Gradient Query
Settings dialog controls the method used for gradient calculations (see that dialog’s help
for more information).

2.4 Defining and Assigning Source Points

When trying to achieve sharp vertical cutoffs, it often helps to use a filament end as the
source point for developing a segment. While the present example reflector doesn’t try to
produce sharp cutoffs, we can still use it to see how this feature works.

First, add a new source point at the inner end of the filament: (0,0,-19). Select Source
> Source Point Properties, and add the new point with the name “Inner Filament End”.
The dialog should look similar to figure 2.6.

Next, select segment S2 and change its aim to a horizontal line by dragging the bottom
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Figure 2.7: S2’s New Aim.

Figure 2.8: Output pattern for segment S2’s with filament end used as source point.

edge up. The resulting aim should look like figure 2.7. Due to the filament’s size, the output
pattern has significant flux up to 2◦ on either side of the horizontal. Note that the peak
vertical gradients (measured with the settings used in section 2.3) vary between 2 and 7.

Finally, with S2 selected, right click in the Reflector view and select Segment Prop-
erties from the popup menu. Change the segment’s source point to the ‘Inner Filament
End’. The output pattern should now resemble figure 2.8. Notice that the output essentially
cutoffs at the horizontal. Peak vertical gradients now range between 4 and 15.

2.5 Aim Balance

In addition to the vertex aim points, ReflectorCAD provides an aim balance point that allows
flux to be directed preferentially to one region of the aim box. Select segment S5. Its aim
balance point (the small cyan square) is currently centered, so its aim balance is neutral.
In this case ReflectorCAD will attempt to spread light evenly throughout the aim region.
Dragging the balance point to one side of the aim region will direct more flux to that side.
Figure 2.9 shows the resulting output patterns for several aim balance positions.
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Figure 2.9: Impact of different aim balance settings on output pattern for segment S5.

2.6 Output Calculation Quality

ReflectorCAD provides a control for output calculation quality in the Output Properties
dialog box. To see the effect of this control on output for a specific segment, first select the

segment S7. Next, select Output > Properties on the menu or press the button. Vary
the Output Calculation Quality setting, noticing that as quality increases the output
becomes smoother and that calculation time increases. Figure 2.10 shows S7’s output for
three quality settings. See section 3.4.1 (page 36) for information on the limitations of
ReflectorCAD’s output calculation method.

2.7 Subsegmenting

In ReflectorCAD a segment’s surface is defined as a grid of second-order bezier patches. The
grid resolution (subsegmenting) for a given segment can be set in its Segment Properties
dialog box. To see how subsegmenting affects output beam performance, first select segment
S13. Next, right click in the Reflector view and select Segment Properties from the popup
menu. Change the subsegmenting, # of subsegments per segment edge, to 3 and click
Ok. Note that the output pattern for S13 now has two prominent hot spots, instead of
the relatively even pattern it produced before. Figure 2.11 shows the output produced by
S13 for different levels of subsegmenting. In each case, the hot spots in the output pattern
correspond to output from a single subsegment, or column of subsegments.
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Figure 2.10: Calculated output for segment S7 at three quality settings.

Figure 2.11: Calculated output for segment S13 with subsegmenting of 3 (top), 5 (middle),
and 7 (bottom).
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Figure 2.12: The top frame shows segment S7 aimed such that horizontal and vertical
aim differences correspond to horizontal (red arrows) and vertical (cyan arrows) spatial
differences, respectively. The bottom frame shows the same segment with horizontal/vertical
aim and spatial differences mismatched.

2.8 Aiming Mismatches

Sometimes ReflectorCAD cannot produce a segment that will achieve the specified aim.
Each aim, when combined with the specified source point, corresponds to a field of surface
normals. ReflectorCAD essentially integrates these surface normals to form the segment’s
surface. But not all normal fields correspond to an actual surface. In such cases, the segment
that’s produced by the integration process may fail to achieve the desired aim.

To illustrate this, consider segment S7. By selecting its various vertices, and noting their
associated aim points, notice that horizontal variations in its aim correspond to horizontal
spatial variations across the segment. Similarly, vertical aim variations correspond to vertical
spatial variations. This is shown in the top frame of figure 2.12. To see what happens when
this correspondance is flipped, select S7 and its lower right vertex in the Reflector view.
Next, in the Output view right click and choose Swap Corners from the popup menu.
This exchanges the aim points of the current vertex with that diagonally opposite it. The
segment’s horizontal/vertical aim and spatial differences are now mismatched and the output
pattern no longer achieves the desired aim, as shown in the bottom frame of figure 2.12. In
general, segments with such mismatches rarely produce the desired pattern.
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Figure 2.13: Shifting a group of vertices. The rectangle shows the vertices to enclose for
shifting.

Figure 2.14: Shifting a group of vertices.

2.9 Moving Groups of Vertices

ReflectorCAD provides an easy way to shift a group of segment vertices by a specific distance
in the X-Y plane. Let’s try out this feature by shifting the vertices that lie along a particular
line in our current reflector. In the Reflector view, while pressing the Control key, hold down
the left mouse button and drag the mouse to enclose the vertices shown in figure 2.13. After
releasing the mouse button, enter the desired shift in the dialog box, as shown in figure 2.14.
This shifts all of the enclosed vertices 10 units to the right. After the shift is performed all
of the affected segments are first reset to the base surface and then redeveloped according to
their aiming. This has the side-effect of undoing any starting point offsets that the affected
segments may have had. As with other segment changes, this change can be undone by
pressing Ctrl-Z or selecting Segment > Undo Last Segment Change from the menu.
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Chapter 3

Overview

This chapter provides an overview of ReflectorCAD.

3.1 Base Surfaces

The base surface serves two purposes in ReflectorCAD. First, it defines the height (Z coor-
dinate) at which the starting point of newly created segments is placed. Second, it specifies
the boundaries of the reflector (in the X-Y plane) that are used for output calculations and
exported with the reflector’s geometry (to an IGES file, for example).

Two types of base surfaces can be used: conic sections with elliptical or racetrack bound-
ers, and sampled surfaces with arbitrary bounders. A utility (IgesToBaseSurf) is provided
for sampling geometry in an IGES file so that it can be used as a base surface.

The base surface is set in the Base Surface Properties dialog (Setup > Base Surface
Properties on the main menu).

3.1.1 Conic Section Base Surfaces

The conic section base surface is defined as follows:

z = f(x, y) =
C (x2 + y2)

1 +
√

1− (1 +K)C2 (x2 + y2)

where C is the curvature (C = 1/Rc, where Rc is the radius of curvature) and K is the
conic constant. For values of x and y where the argument of the square root is negative,
f(x, y) = C (x2 + y2) is used. A parabolic base surface, for example, would have a conic
constant of K = −1 and a focal length of Rc/2.

The outer and inner boundaries of the surface can be either ellipses or racetracks (rect-
angular with rounded corners).

3.1.2 Sampled Base Surfaces

The sampled base surface is defined as an evenly spaced grid of height (Z) values, which are
read from a distribution (*.dis) file produced by either ASAP (using the MAP command) or
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the IgesToBaseSurf utility (which ships with ReflectorCAD). Through sampling, essentially
arbitrary geometry can be used as the base surface.

Sample heights that lie outside of the surface’s boundary are marked in the distribution
file when it is generated. The boundary of the base surface in ReflectorCAD is defined as the
curve or curves that separate in-bounds and out-of-bounds samples. Therefore, the accuracy
of the bounding curves is determined by the resolution at which the sampled surface was
produced.

Sampling Geometry in ASAP

To height-sample geometry in ASAP for use as a base surface:

• Run whatever commands are necessary to define your geometry and system units.

• Make certain your geometry is oriented so that the desired surface faces along the
Z-axis.

• Set your graphics window to look down the Z-axis using the command WINDOW Y
X.

• Run the MAP command with the desired filename and resolution parameters. For
example, the command, MAP BASE.DIS PIXEL 201 creates a sampled surface
with a side resolution of 201 pixels in the file, BASE.DIS.

Sampling Geometry in IGES Files

The IgesToBaseSurf utility, included with ReflectorCAD, height samples geometry in an
IGES file so it can be used as a base surface. As with ASAP, the geometry should be
oriented to face along the Z-axis. To achieve this alignment, up to three rotations can be
applied within IgesToBaseSurf before sampling. See the online help in IgesToBaseSurf for
more information.

3.2 Sources

Source models for several common bulbs are included with ReflectorCAD. Each is defined in
its own binary Source Definition (SDF) file. In the case where a bulb has more than one
operating mode (for example, a headlamp bulb might have a high and low-beam setting),
there is an SDF file for each mode.

Sources are selected, positioned, and oriented in the Source Properties dialog, accessed

by selecting Source > Properties on the main menu or by pressing the button. Up to
two sources can be chosen, but only one can be on at a time. For example, selecting Source

> Source 1 On or clicking the button will turn on source number one and turn off

source number two. The button toggles between sources one and two.
Each bulb model has primary and secondary axes. Typically, the primary lies along the

bulb’s long axis, or the axis of symmetry for the bulb’s envelope (usually these are the same
axis). The secondary axis is always perpendicular to the primary and usually is aligned
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Figure 3.1: The ASAP geometric model for the 9005 headlamp bulb and the corresponding
ReflectorCAD source model facets (left). The cylinder of facets near the filament (shown
closeup in the right figure with directional apodization data included) carries roughly 90%
of the model’s flux. The remaining flux is captured on the cylinder that surrounds the bulb.

with some structural feature of the bulb. Clicking the View Model button in the Source
Properties dialog displays information on how the primary and secondary axes are defined
for the currently selected bulb.

Sources are modelled as collections of facets, each emitting light from its center accord-
ing to its own directional apodization data. The models that ship with ReflectorCAD are
created from the rays of their corresponding ASAP light sources. The rays are propagated
to facets and then binned directionally. The best focus of the rays becomes the Effective
Filament Position (EFP) for the source. The EFP is used, by default, as the source
point during segment development. A source’s EFP is displayed when it is selected in the
Source Properties dialog. Figure 3.1 shows an example of an ASAP light source and its
corresponding ReflectorCAD model facets.
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3.2.1 Creating a Source

A ReflectorCAD source can be created from almost any collection of rays in an ASAP
distribution (*.dis) file.

To create such a distribution file in ASAP:

• Make sure the XMEMORY setting is either MIN (preferably) or NORM.

• Execute whatever commands are necessary to define your source (making sure that
system units are defined in the process).

• Orient your source so that its intended primary axis lies along the positive Z-axis and
the secondary axis lies along the positive Y-axis.

• Execute the command DUMP FILENAME.DIS to dump the current rays to a
distribution file.

Two equivalent source conversion programs, Dis2SdfGui and Dis2Sdf , are provided with
the ReflectorCAD distribution. Dis2SdfGui has a wizard-based graphical interface and can
be run from the Start > Programs > ReflectorCAD menu. Specific help for Dis2SdfGui
is available via the Help button on its dialog boxes. Dis2Sdf has a simple command line
interface. The -h command line option provides limited help for Dis2Sdf .

3.3 Segments

In ReflectorCAD, segments are the fundamental elements used to build a reflector. Each
segment has four vertices. One vertex, called the starting point, is designated as the point
from which the rest of the segment is developed. Each vertex has an aim point associated with
it. From these aim points, and a chosen source point, surface normals for the segment are
determined. The normals are then integrated from the starting point to form the segment’s
surface.

The starting point is the only vertex of a segment whose height can be changed. By
default, it is the first vertex laid down when a segment is created. Following segment creation,
any vertex can be specified as the starting point on its Vertex Properties dialog (accessed
by selecting Vertex Properties on the popup menu in the Reflector view).

This section describes the various segment-related operations available in ReflectorCAD.

3.3.1 Creating Segments

To create a rectangular segment:

• Select the Segment > Create (rectangular) menu item or click the button.

• Move the mouse to the desired location of the segment’s first vertex and click.

• Move the mouse to the segment’s opposite vertex and click.
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The first vertex will be placed at the height of the base surface and serve as the segment’s
starting point (the starting point can be switched to another vertex later). If desired, segment
creation can be terminated prematurely by pressing the Esc key. To create an arbitrary four-
sided segment:

• Select the Segment > Create (arbitrary 4-sided) menu item or click the button.

• Move the mouse to the desired location of the segment’s first vertex and click.

• Similarly place the segment’s second, third, and fourth vertices.

During segment creation, snapping is available. To toggle this feature on or off, right-click
in the Reflector view and select Enable Grid and Snapping from the popup menu. The
grid and snap settings can be changed by selecting Grid/Snap Settings from the same
popup menu.

3.3.2 Selecting Segments and Vertices

A segment is selected by clicking anywhere inside its boundaries. Only one segment can be
selected at a time. The selected segment is drawn in red to distinguish it from the others.
Its corresponding output (if available) and aim points are displayed in the Output view.

Additionally, the vertex that was closest to the cursor is also selected and drawn with a
small green box in both the Reflector and Output views. A different vertex can be selected
by pressing the Tab or Shift-Tab keys, or by clicking near it within the segment. A vertex
can also be selected by clicking near its aim point in the Output view.

Once a segment is selected, the keyboard arrow keys can be used to move to and select
adjacent segments.

3.3.3 Aiming Segments

Segments are initially assigned a default aim when they are created. This default aim can
be changed by selecting the Segment > Default Aiming menu item. A segment can be
set to the default aim at any time by selecting Aim to Defaults on the popup menu in the
Reflector view.

Once a segment is selected, there are several ways to alter its aim. A single aim point
can be moved by dragging it with the left mouse button down. Similarly, an adjacent pair
of aim points can be moved simultaneously by dragging the red box that’s between them.
All four aim points can be moved together by selecting Move on the popup menu in the
Output view.

In addition to the vertex aim points, ReflectorCAD provides an aim balance point that
allows flux to be directed preferentially to one region of the aim box. By default a segment’s
aim balance point (drawn as a small cyan square) is centered, so its aim balance is neutral.
Dragging the balance point to one side of the aim box directs more flux to that side. Neutral
aim balance can be restored by selecting Make Aim Balance Neutral from the popup
menu in the Output view.
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3.3.4 Redeveloping Segments

Each time a segment’s aim changes, ReflectorCAD automatically reshapes the segment to
achieve the desired aim. This is called developing the segment. The aim is used, along with
the specified source point, to determine the necessary surface normals. These normals are
in turn integrated, beginning at the starting point, to form the segment’s new shape.

During integration, the segment’s prior shape is used as an approximation for its new
shape to help evenly balance flux across the aim region. To the extent that the prior and new
shapes are similar, this approximation is good. If a segment’s shape changes substantially
its performance can often be improved by redeveloping it after the last aim change.

To redevelop a segment, first ensure it is selected. Then right click in the Reflector view
and select Redevelop from the popup menu. All segments can be redeveloped by selecting
Segment > Redevelop All Segments from the main menu.

3.3.5 Mirroring Segments

It is common for a segmented reflector to be essentially symmetric across one or both axes.
To make creating such reflectors easier, ReflectorCAD can mirror a single segment or all
segments.

To mirror the currently selected segment, select Mirror Selected Segment from the
popup menu in the Reflector view. To mirror all segments select Segment > Mirror
Existing Segments from the main menu.

3.3.6 Shifting Groups of Vertices

Groups of vertices can be shifted simultaneously in the X and Y directions. While holding
down both the Ctrl key and left mouse button, drag the mouse to select a rectangular region
that encloses the vertices of interest. When the mouse button is released enter the desired
shift in the Shift Multiple Vertices dialog that appears. After being reset to the base
surface, all affected segments will be redeveloped according their assigned aim points.

3.3.7 Checking Edge Shadowing

For both performance and manufacturability reasons it is generally desirable to minimize
height discontinuities between adjacent segments. Where such discontinuities are necessary
they should normally be hidden from the source (in otherwords, shadowed) to prevent un-
desired stray reflections. This can be done by adjusting segment aims and/or starting point
heights. ReflectorCAD provides a simple method for checking whether a discontinuity is
hidden from the source.

• First select one of the two segments that share the edge of interest.

• Then move the mouse to the other segment that shares this same edge and hold down
the Shift key and left mouse button simultaneously.

While the buttons are depressed, a titletip will display the maximum height of the more-
distant segment’s edge relative to the closer segment’s edge. If the discontinuity is shadowed
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then the titletip message will be green, if not then it will be red. If the edge of interest lines
up with the current source’s effective filament position, no height value is reported because
neither segment can shadow the filler

3.3.8 Undoing Segments Changes

Changes made to segments, including the creation of new segments by mirroring or other
methods, can be undone by selecting Segment > Undo Last Segment Change from the
main menu or by pressing Ctrl-Z. Up to the last five changes can be undone.

3.4 Calculating Output

ReflectorCAD can quickly calculate the approximate output from the reflector. Select Out-

put > Calculate Output from the menu or click the button to calculate the output.
If Output > Auto Update is checked, output is automatically calculated every time a
change is made that effects the output.

If up-to-date output is available it is displayed in the Output view. When a segment is
selected, only its output is displayed. Otherwise the total output of all segments is shown.

Either directional (luminous intensity) or positional (illuminance) output can be calcu-
lated. For directional output, angles are defined relative to a horizontal pole. Detector
screen limits, resolution, and distance (for positional output) are all setable in the Output
Properties dialog (which is accessed by selecting the Output > Properties menu item

or clicking the button). Output can be scaled, to account for the reflector’s reflectivity
or the transmissivity of a clear lens. Calculation quality can also be adjusted.

The Output Appearance dialog (accessed by selecting Output > Appearance from
the menu) is used to control how output is drawn. The color palette, whether contours are
displayed, and tick mark spacing are among the things that can be changed. Contour levels
and colors are set in the Output Contour Properties dialog (Output > Contouring
on the menu).

3.4.1 How Output is Calculated

Reflector output is calculated using BRO’s Deterministic Specular Radiative Transfer (DeSeRT)
algorithm. Using approximations applicable to typical reflector systems, this high-speed al-
gorithm provides nearly immediate feedback on how a reflector is performing. The output
calculation has the following limitations:

• It ignores shadowing effects. All in-bounds portions of a segment can contribute to the
output, even though they may be in the shadow of an adjacent segment. For reflectors
with large intersegment discontinuities, and correspondingly large shadows, this can
be a significant effect. In practice the shadowed regions of a typical reflector are often
very small and the resulting overestimate will be, at most, a few percent of the total
flux.
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• It ignores direct transfer from the source to the detector screen. This typically is a
small effect and leads to an underestimate of the total output flux. For reflectors
with bulbs that have blockers or blackened caps there would not be appreciable direct
transfer.

• It ignores multiple bounces off of the reflector.

• It ignores interactions with intersegment fillers. Typically, effort is spent hiding inter-
segment discontinuities from the light source because they lead to spurious, unaimed,
reflections. To the extent that they are hidden, ignoring fillers in the output calcula-
tion has no significant effect. Unfortunately, if a reflector has fillers that are visible to
the light source, they can have serious deleterious effects on its performance that will
NOT be seen in the approximate output calculation. In such cases further analysis
with a high quality package, like ASAP, is especially important. Intersegment fillers
are (optionally) included when reflector geometry is exported to ASAP or IGES, to
make this task easier.

In the end it is important to keep in mind that ReflectorCAD provides a quick, but ap-
proximate, calculation of the reflector’s output. While this approximate output can provide
very useful feedback during the design process, performing final analyses with a high quality
package, like ASAP, is still necessary.

3.5 Three-Dimensional Preview

A three-dimensional preview of the reflector can be generated by selecting View > Gen-

erate 3D View from the menu, clicking the button, or by pressing the P accelerator
key. A separate window will open with a faceted representation of the segments, interseg-
ment fillers (optionally), and source model. The view can be rotated by moving the mouse
while holding down the right mouse button. The 3D Viewer has help describing the other
manipulations that are available.

Segment faceting, color, and filler creation are controlled in the Segment 3D View
Properties dialog (accessed by selecting Segment > 3D View Properties on the menu).
The method for displaying the source model is controlled in the Source 3D View Proper-
ties dialog (Source > 3D View Properties on the menu). Both dialogs have online help
available for their detailed options.

The three-dimensional preview geometry can also be exported directly to an ASAP vector
(VCR) file for later viewing. Select File > Export > To VCR on the menu to do this.

3.6 Exporting Geometry

A reflector design can be exported to an ASAP input (INR) file or an IGES file. In either
case intersegment fillers can be (optionally) included. It is important to note that the fillers
generated by ReflectorCAD do NOT have draft angles, and that segment edges are not
radiused. So additional work will be required to produce the finished geometry for mold-
making purposes.
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3.6.1 Exporting to ASAP

Segment geometry can be exported to an INR file by selecting File > Export > To ASAP
from the menu. Bounders, intersegment fillers, source definitions, and analysis commands
can also be optionally included in the INR file.

INR files exported from ReflectorCAD use stored raysets as source models. To run
the exported file in ASAP, the raysets corresponding to the sources used in ReflectorCAD
need to be present. This may require downloading the relevant source files. Consult the
documentation included with ASAP for more information.

3.6.2 Exporting to IGES

All reflector segments and, optionally, intersegment fillers and source points can be exported
directly to an IGES file by selecting File > Export > To IGES on the menu. Any
bounders associated with the base surface, while included in the IGES file, will not actually
be imposed on the segments or fillers.
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Appendix A

A Comparison of Output Calculated
by ReflectorCAD and ASAP

This short note compares output calculated by ReflectorCAD and ASAP, for the ‘Visu-
alAimLowBeam’ example that ships with ReflectorCAD 1.5. This reflector is not an actual
headlamp – it is the first-pass at a conceptual design intended to meet the visual aim stan-
dard.

Figures A.1 and A.2 show the output calculated by ReflectorCAD and ASAP, respec-
tively. Comparing contours, the results agree nicely. The peak output values are 31,637
for ReflectorCAD and 32,664 for ASAP, while total flux on the screen is 575.9 lumens for
ReflectorCAD and 594 for ASAP. The approximate output calculated by ReflectorCAD does
not include light that travels from the source directly to the screen, while the ray trace per-
formed in ASAP includes everything. Consequently we would expect the numbers from
ASAP to be slightly larger than those from ReflectorCAD. A separate ray trace, with just
the source and detector screen, was performed to quantify this effect. The total flux due
to direct illumination was found to be 16.5 lumens. Subtracting it from the total figure for
ASAP, we now get 577.5 lumens for the total flux, which agrees very nicely with the value
calculated by ReflectorCAD.

On a 500 Mhz Pentium-series processor, ReflectorCAD took 30 seconds to calculate
output for the entire reflector. Since most design changes affect only a portion of the reflector,
output can typically be updated in just a few seconds when working in ReflectorCAD. ASAP
took a little more than 2 hours to perform the calculation, using 2 million rays (pretraced
through the bulb’s geometry) for the source model. The bulb’s geometry was not present
during the trace with the reflector. The ASAP results were averaged horizontally (using the
AVERAGE 0 2 command).

It is also interesting to compare vertical gradients in the region between 1 and 3 de-
grees right. Figure A.3 shows three screendumps of the interactive gradient-query tool in
ReflectorCAD for this region. The gradient, in this case, is calculated as a partial derivative
along the vertical direction. Peak values vary between 23,700 and 26,400. Figure A.4 shows
the relevant results from ASAP. Peak derivative values vary between 23,300 and 25,600.

For purposes of headlamp testing, vertical gradients are typically not defined as deriva-
tives. For example, SAE J1735 of January 1995 (Harmonized Vehicle Headlamp Performance
Requirements) defines the vertical gradient as G(v) = [I(v− 0.2)− I(v)]/I(v), where I(v) is
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Figure A.1: Output calculated by ReflectorCAD. Resolution is 70 pixels vertical and 100
pixels horizontal. Calculation quality was at the middle (default) setting. The standard
ReflectorCAD source model for the 9005 bulb (with roughly 600 facets) was used.

Figure A.2: Output calculated by ASAP. Resolution is 70 pixels vertical and 243 pixels
horizontal.

Figure A.3: Vertical derivative for output slices along 1, 2 and 3 degrees right, as measured
in ReflectorCAD using the gradient query feature.
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Figure A.4: Vertical slices along 1, 2 and 3 degrees right, showing the output (left) and
vertical partial derivative of the output (right), as calculated by ASAP.

Figure A.5: Vertical gradients for slices of output along 1, 2 and 3 degrees right, as calculated
by ReflectorCAD.

the intensity at vertical angle v (measured in degrees). Using this definition, screendumps of
the gradient measurement in ReflectorCAD are shown in figure A.5. Peak values range from
0.857 to 0.994. The corresponding plots for the output calculated by ASAP are shown in fig-
ure A.6. Peak values, ranging from 0.857 to 0.887, agree well with those from ReflectorCAD.
Figure A.7 shows the gradient query settings used in ReflectorCAD for the screen captures
shown in figure A.5.

Table A.1 summarizes the results of this comparison. Overall, there is good agreement.
It is important to remember that the quick output engine in ReflectorCAD makes use of
several approximations, the validity of which can vary between reflectors. While for typical
uses it will achieve accurate results, it is still important to verify the performance of finished
designs using a more complete analysis package like ASAP. See section 3.4.1 (page 36) for
more information on the limitations of ReflectorCAD’s quick output engine.
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Figure A.6: Vertical gradient for slices of output along 1, 2 and 3 degrees right, as calculated
by ASAP.

Figure A.7: Gradient query settings used in ReflectorCAD for measurements shown in fig-
ure A.5.

42



Quantity ReflectorCAD ASAP

Total Lumens 575.9 594
direct illum. subtracted 577.5

Peak Candela 31,637 32,664
Calculation Time ∼ 30 seconds ∼ 2 hours
Peak Vertical Derivatives

1◦ Right 26,400 25,600
2◦ Right 23,700 23,300
3◦ Right 24,600 24,200

Peak Vertical Gradients
1◦ Right 0.887 0.887
2◦ Right 0.994 0.857
3◦ Right 0.857 0.859

Table A.1: Summary of results calculated by ReflectorCAD and ASAP.
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Appendix B

Notes for TightCutoffSegments
Example

These are notes to accompany the file ‘TightCutoffSegments.rdf’, which is included with
ReflectorCAD in the ‘Visual Aim Headlamp’ example directory. After loading the file in
ReflectorCAD, the reflector view should look similar to the figure below.

Make sure output has been calculated for the reflector by clicking the button. Select
segment S1 by clicking inside it with the mouse. Its output will be shown in the output view.
While S1 is selected, right click in the Reflector view and select Segment Properties.
Notice that the Source Point for this segment is the inner edge of the filament. This
provides for a tighter cutoff on the upper boundary of its aim region. To see this effect,
change the Source Point to be ‘EFP of Src #1’ (essentially the filament’s center). The
figure below shows the output of S1 when developed using the filament center (left) and the
filament’s inner edge (right) as the source point. In both cases the segment is aimed to a
horizontal line.
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When the filament’s inner edge is used, vertical gradients in the 0.2 to 0.4 range are calculated
in ReflectorCAD, using the gradient query settings shown in the figure below (this dialog
is accessed by right clicking in the Output view and selecting Gradient Query Settings
from the popup menu).

To calculate gradients in the Output view, hold down the Control key and left mouse button
simultaneously.

Segment S2 was developed using the bottom center of the filament as the source point.
The figure below shows the output of S2 when developed using the filament center (left) and
the filament’s bottom center (right) as the source point.

When the bottom center is used as the source point, the output pattern stays below the
segment’s horizontal aim line. Calculated gradients vary between 0.3 and 0.5 along the top
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of this output pattern. The figure below shows the gradient query results from one location
in the pattern.

Segment S3 employs the same idea as S1, except that the outer filament end is used as
the source point because the segment is below the filament. Segment S4 uses the bottom
center of the filament, just as S2 does.
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Appendix C

Release Notes

C.1 ReflectorCAD 1.5

C.1.1 Backward Compatibility

You can open files in ReflectorCAD 1.5 that were generated by previous versions of the
product. However, previous versions of ReflectorCAD cannot open files that are generated
by version 1.5.

C.1.2 What’s New in 1.5

Import of IGES Base Surfaces A new utility, IgesToBaseSurf, translates IGES files to
sampled base surfaces without the need for ASAP.

Positional Output The quick approximate output engine in ReflectorCAD can now cal-
culate positional output (illuminance), in addition to directional output (luminous
intensity).

Gradient Measurement A graph tip allows vertical gradients to be determined using the
mouse.

New Sources Approximately 85 sources are now available in ReflectorCAD. Sources are
now faceted more finely for improved output calculation accuracy.

User-Defined Source Points Additional user-defined source points can be positioned, at
filament ends for example, to improve segment performance.

Assigned Source Points A segment can be assigned a specific source point. For example,
a segment associated with the low beam of a headlamp can be assigned to always use
the low beam source point when developed.

Alternate Segment Developer An alternate segment integration pattern provides more
control over segment performance.
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Improved Built-in Base Surfaces The conic section base surface can now be shifted
(which allows the focus to be at the origin). The ‘racetrack’ shape was added as a
bounder.

Easier Aim Adjustments All corners and edges of the aim region can now be immediately
dragged to a different position. The aim balance is easily distinguished from other aim
region points.

Updated 3D Viewer Support A new 3D Viewer is included with ReflectorCAD. Similar
to the 3D Viewer in ASAP, it includes such features as an object name tree and mouse-
based object selection.

Source Positions Exported to IGES All source positions can be exported, optionally,
to an IGES file along with the reflector geometry.

Configuration Preferences Many settings, including units, can be saved as defaults for
new reflectors.

New Quick Tour As part of the revised documentation, a new quick tour is included to
show off some of the new features.

C.1.3 Minor Enhancements

• Edge shadow heights and data values are now reported in tool tips for enhanced read-
ability.

• The default system units are now millimeters.

• Units have been added to the output and reflector views.

• Keyboard accelerators and toolbar buttons have been provided for some common op-
erations, including switching between sources, creating rectangular segments, and cal-
culating output.

• A list of the most recently used files is now maintained on the file menu.

• The end-of-line character used for exported IGES files can now be set.

C.1.4 Bug Fixes

• Zero-range map files (for sampled base surfaces) caused ReflectorCAD to hang.

• Sources could be positioned improperly in ASAP if user preferences specified different
units than were used in ReflectorCAD.

• Temporary 3D Viewer files were being written to the current working directory.

• The aim balance point could be unmovable if the segment had a zero spread aim in
one direction.

• Contours were being drawn as dashed lines in the output view.
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